[hdoj_1005]Number Sequence

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1005


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining


题目大意:

1.多组测试数据,依次输入A,B,n(1 <= A, B <= 1000, 1 <= n <= 100,000,000),输入0 0 0 终止;

2.f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7;

3.输出 f(n)。

解题思路:

1.n的数值很大,这类数值很大的问题一般都有规律,找出循环节(周期)是关键;

2.找规律,这道题是从 f(1) = 1 和 f(2) = 1 开始,然后依次模7,可知 f(n) 只有7种情况,所以两数相邻只有7*7=49种;

3.所以从 f(1) 到 f(49) 必会出现相邻两个 f(m-1) = 1 , f(m) = 1,所以 f(n) 为周期函数,49为其一个周期;

需要注意的地方:

做题的时候不要盲目的上手去做,先要仔细分析题目,先动脑再动手。

代码如下:

// hdoj_1005 Number Sequence
// 31MS	220K	370 B	GCC

#include <stdio.h>

int fun(int a, int b, __int64 n);

int main(void)
{
	int a, b;
	__int64 n;
	while(scanf("%d%d%I64d", &a, &b, &n) && a != 0 && b != 0 && n != 0)
	{
		printf("%d\n", fun(a, b, n%49));
	}
	return 0;
}

int fun(int a, int b, __int64 n)
{
	if(n == 1 || n == 2)
		return 1;
	else
		return (a*fun(a, b, n-1) + b*fun(a, b, n-2)) % 7;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值