POJ--1979 Red and Black

                                                                                                                                                Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 28331 Accepted: 15416

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
典型的DFS例题,很简单的一道水题;
以下是AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<stack>
#include<queue>
#include<string>
#include<vector>
#define rep(i,a,n) for(int i=a;i<n;i++)
#define per(i,n,a) for(int i=n;i>a;i--)
#define mem0(x) memset(x,0,sizeof(x))
#define memff(x) memset(x,INF,sizeof(x))
#define INF 100000000
using namespace std;
typedef pair<int,int> P;
typedef long long LL;
char maze[25][25];
int dw[4]={0,1,0,-1},dh[4]={1,0,-1,0};
int cal;
int nw,nh;
int w,h;
void DFS(int sw,int sh)
{
    maze[sh][sw]='#';
    for(int i=0;i<4;i++)
    {
        nw=sw+dw[i];nh=sh+dh[i];
        if(1<=nw&&nw<=w&&1<=nh&&nh<=h&&maze[nh][nw]!='#')
        {
            cal++;
            DFS(nw,nh);
        }
    }
}
int main()
{
    //freopen("input.in","r",stdin);
    int sw,sh;
    while(cin>>w>>h)
    {
        if(w==0&&h==0)break;
        cal=1;
        for(int i=1;i<=h;i++)
        {
            for(int j=1;j<=w;j++)
            {
                cin>>maze[i][j];
                if(maze[i][j]=='@')
                {
                    sw=j;sh=i;
                }
            }
        }
        DFS(sw,sh);
        cout<<cal<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值