POJ 1979 Red and Black (深度优先遍历)

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 22768 Accepted: 12286

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

===

题目解析:

第一步:先定义一个变量result,存储黑块的数目

第二部:和迷宫问题类似,我们假设这个人站在点(i,j),我们可以先对这个点进行DFS,然后对点(i,j)的上下左右的点也进行DFS

第三步:如果进行DFS的点满足如下条件

-------------该点不是"#",那么就将result+1,并且把这个点设置为“#”,并且对该点进行第二步的操作。



附上AC过的代码:

#include<iostream>
using namespace std;
#define MAX 30
int W,H;
int result;
char Graph[MAX][MAX];
int direction[4][2]={{0,1},{0,-1},{-1,0},{1,0}};  


void DFS(int p,int q)
{
	int i;
	if(p>=0 &&p<=W-1 &&q>=0 &&q<=H-1 &&Graph[p][q]=='.')
	{
		result++;
		Graph[p][q]='#';
	}
	else
	{
		return ;
	}
    for(i=0;i<4;i++)
	{
		int x=p+direction[i][0];
		int y=q+direction[i][1];
		DFS(x,y);
	}
}

int main()
{
	int i,j,p,q;
	while(cin>>H>>W)
	{
		//注意应该在这里设置初始化,不要在全局变量设置初始化,不然会WA
		result=0;
		memset(Graph,0,sizeof(Graph));
		if(H==0 &&W ==0)
			break;
		for(i=0;i<W;i++)
		{
			for(j=0;j<H;j++)
			{
				cin>>Graph[i][j];
				if(Graph[i][j]=='@')
				{
					p=i;
					q=j;
					Graph[i][j]='.';
				}
			}
		}
		DFS(p,q);
		cout<<result<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值