POJ--3481 Double Queue

Double Queue
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13060 Accepted: 5883

Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

0The system needs to stop serving
1 K PAdd client K to the waiting list with priority P
2Serve the client with the highest priority and drop him or her from the waiting list
3Serve the client with the lowest priority and drop him or her from the waiting list

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input

2
1 20 14
1 30 3
2
1 10 99
3
2
2
0

Sample Output

0
20
30
10
0

简单的map操作即可AC,由于是训练赛碰见的,所以代码里面有一些奇怪的东西,希望大家无视~
以下是我的AC代码:
/*Tao是秋名山车神~*/
/*希望一次性飙车成功*/
/*Tao~kimoji~ya~mie~die*/
/*不行了~估计要被打死*/
#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector>
#include<map>
#include<cmath>
#include<stack>
#include<algorithm>
#include<queue>
#define mem0(x) memset(x,0,sizeof(x))
#define memff(x) memset(x,0xff,sizeof(x)
#define rep(a,i,n) for(int i=a;i<n;i++)
#define per(n,i,a) for(int i=n;i>a;i--)
#define rep5(a,i,n) for(i=a;i<=n;i+=5)
#define MOD 1e9+7
#define N 1100
#define M 100010
#define INF 0xffff
using namespace std;
int main()
{
    //freopen("input.in","r",stdin);
    map<int,int> Taoliqiang;
    int a,b,n;
    while(scanf("%d%*c",&n)!=EOF)
    {
        if(n==0) break;
        if(n==1)
        {
            scanf("%d%d",&a,&b);
            Taoliqiang.insert(map<int,int>::value_type(b,a));/*b->权限&a->顾客代号*/
        }
        if(n==2)/*输出权限大的顾客带号*/
        {
            if(Taoliqiang.empty())
            printf("0\n");
            else
            {
                printf("%d\n",Taoliqiang.rbegin()->second);
                Taoliqiang.erase(Taoliqiang.find(Taoliqiang.rbegin()->first));
            }
        }
        if(n==3)/*输出权限小的顾客带号*/
        {
            if(Taoliqiang.empty())
            printf("0\n");
            else
            {
                printf("%d\n",Taoliqiang.begin()->second);
                Taoliqiang.erase(Taoliqiang.begin());
            }
        }

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值