【Treap模板题】 POJ - 3481 Double Queue

A - Double Queue  POJ - 3481 

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

0The system needs to stop serving
KPAdd client K to the waiting list with priority P
2Serve the client with the highest priority and drop him or her from the waiting list
3Serve the client with the lowest priority and drop him or her from the waiting list

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input

2
1 20 14
1 30 3
2
1 10 99
3
2
2
0

Sample Output

0
20
30
10
0
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1e5+10;
int rt=0,cnt=0;
struct node
{
    int key,num,rand,son[2];
}T[maxn];

void rot(int &x,int p)  //1 为右旋  0 为左旋
{
    int y=T[x].son[!p];
    T[x].son[!p]=T[y].son[p];
    T[y].son[p]=x;
    x=y;
}

void ins(int &x,int key,int num)
{
    if(x==0)
    {
        x=++cnt;
        T[x].key=key,T[x].num=num,T[x].rand=rand(),T[x].son[0]=T[x].son[1]=0;
    }
    else
    {
        //如果插入的数比之前的小,就放到他的左子树,不然插入他的右子树
        int p=key<T[x].key;
        ins(T[x].son[!p],key,num);
        if(T[x].rand<T[T[x].son[!p]].rand) rot(x,p);  //如果父亲节点的优先级小于其插入的值的优先级的话,就旋转
    }
}

void del(int &x,int key)
{
    if(T[x].key==key)  //就是我要删掉的那个
    {
        if(T[x].son[0]&&T[x].son[1]) //左右节点都不为空
        {
            int p=T[T[x].son[0]].rand>T[T[x].son[1]].rand; //左节点优先级大于右节点右旋,否则左旋
            rot(x,p);
            del(T[x].son[p],key);
        }
        else
        {
            if(!T[x].son[0]) x=T[x].son[1]; //左节点为空,父亲节点变为右节点
            else x=T[x].son[0];
        }
    }
    else  //如果当前节点值>我要找的了,找左子树,不然找右子树
    {
        int p=T[x].key>key;
        del(T[x].son[!p],key);
    }
}

int get(int x,int p)
{
    while(T[x].son[p])
        x=T[x].son[p];
    return x;
}

int main()
{
    int Q;
    while(~scanf("%d",&Q)&&Q)
    {
        if(Q==1)
        {
            int num,key;  //数和优先级
            scanf("%d%d",&num,&key);
            ins(rt,key,num);
        }
        else if(Q==2)
        {
            int x=get(rt,1);
            if(x)
            {
                printf("%d\n",T[x].num);
                del(rt,T[x].key);
            }
            else printf("0\n");
        }
        else
        {
            int x=get(rt,0);
            if(x)
            {
                printf("%d\n",T[x].num);
                del(rt,T[x].key);
            }
            else printf("0\n");
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值