[bzoj2763][最短路]飞行路线

109 篇文章 4 订阅
20 篇文章 0 订阅

Description

Alice和Bob现在要乘飞机旅行,他们选择了一家相对便宜的航空公司。该航空公司一共在n个城市设有业务,设这些城市分别标记为0到n-1,一共有m种航线,每种航线连接两个城市,并且航线有一定的价格。Alice和Bob现在要从一个城市沿着航线到达另一个城市,途中可以进行转机。航空公司对他们这次旅行也推出优惠,他们可以免费在最多k种航线上搭乘飞机。那么Alice和Bob这次出行最少花费多少?

Input

数据的第一行有三个整数,n,m,k,分别表示城市数,航线数和免费乘坐次数。
第二行有两个整数,s,t,分别表示他们出行的起点城市编号和终点城市编号。(0<=s,t小于n)
接下来有m行,每行三个整数,a,b,c,表示存在一种航线,能从城市a到达城市b,或从城市b到达城市a,价格为c。(0<=a,b小于n,a与b不相等,0<=c小于等于1000)

Output

只有一行,包含一个整数,为最少花费。

Sample Input

5 6 1
0 4
0 1 5
1 2 5
2 3 5
3 4 5
2 3 3
0 2 100

Sample Output

8

HINT

对于30%的数据,2<=n<=50,1<=m<=300,k=0;

对于50%的数据,2<=n<=600,1<=m<=6000,0<=k<=1;

对于100%的数据,2<=n<=10000,1<=m<=50000,0<=k<=10.

题解

二维spfa,很好的思维题
将spfa中d数组增加一维,队列也增加一维
d[x][i]表示0~x用了i次机会的最小值
list[x][0]表示就是原spfa中的list[x]
list[x][1]表示到x这个点用了多少次次数
然后判一下类似dp继承这样跑一跑spfa就可以了

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<cmath>
using namespace std;
struct node
{
    int x,y,c,next;
}a[210000];int len,last[110000];
void ins(int x,int y,int c)
{
    len++;
    a[len].x=x;a[len].y=y;a[len].c=c;
    a[len].next=last[x];last[x]=len;
}
bool v[110000][11];//v不解释= =看下面 
int list[110000][11];//list[i][0]表示的是队列里面第i个点,[i][1]表示用了多少次机会 
int d[110000][11],head,tail;//d[i][j]表示第i个点用了j次机会的最短路 
int main()
{
    int n,m,kk,st,ed;
    len=0;memset(last,0,sizeof(last));
    scanf("%d%d%d%d%d",&n,&m,&kk,&st,&ed);
    for(int i=1;i<=m;i++)
    {
        int x,y,c;
        scanf("%d%d%d",&x,&y,&c);
        ins(x,y,c);
        ins(y,x,c);
    }
    memset(d,31,sizeof(d));d[st][0]=0;
    memset(v,false,sizeof(v));
    v[st][0]=true;list[1][0]=st;list[1][1]=0;
    head=1;tail=2;
    while(head!=tail)
    {
        int x=list[head][0],c=list[head][1];
        for(int k=last[x];k;k=a[k].next)
        {
            int y=a[k].y;
            if(d[x][c]+a[k].c<d[y][c])//最普通的最短路= =不用免费次数 
            {
                d[y][c]=d[x][c]+a[k].c;
                if(v[y][c]==false)
                {
                    v[y][c]=true;
                    list[tail][0]=y;
                    list[tail++][1]=c;
                    if(tail==100001)tail=1;
                }
            }
            if(d[x][c]<d[y][c+1] && c<kk)//用次数 
            {
                d[y][c+1]=d[x][c];
                if(v[y][c+1]==false)
                {
                    v[y][c+1]=true;
                    list[tail][0]=y;
                    list[tail++][1]=c+1;
                    if(tail==100001)tail=1;
                }
            }
        }
        head++;
        if(head==100001)head=1;
        v[x][c]=false;
    }
    int ans=999999999;
    for(int i=0;i<=kk;i++)ans=min(ans,d[ed][i]);//最后for一发入魂 
    printf("%d\n",ans);
    return 0;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值