SPFA+Stack||Dijkstra+Heap-POJ-3159-Candies

Candies
Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 26380 Accepted: 7238
Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4
Sample Output

5
Hint

32-bit signed integer type is capable of doing all arithmetic.
Source

POJ Monthly–2006.12.31, Sempr

刚看到题的时候想到的是dijikstra,但是看了看discuss,又放弃了用dijkstra算法的想法,改为用今天刚刚看的spfa,同时鉴于discuss中血淋淋的惨例,我一开始就直接用手写stack来spfa,一次ac,我也没想到会这样- -下次再研究下dijkstra+heap吧。(最新更新:dijkstra堆优化+手写邻接表做法,代码在后面。)

//
//  main.cpp
//  最短路练习-K-Candies
//
//  Created by 袁子涵 on 15/10/16.
//  Copyright © 2015年 袁子涵. All rights reserved.
//
//  579ms   4172KB

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

#define MAXPT 30005
#define MAXEG 150005
#define INF 0xFFFFFFFF

using namespace std;

typedef struct edge
{
    long long int fin,wt,next;
}Edge;

Edge eg[MAXEG];
bool visit[MAXPT];
long long int N,M,dis[MAXPT],pre[MAXPT];

typedef struct stack
{
    long long int top,data[MAXPT];
}Stack;

Stack s;

void spfa()
{
    long long int now;
    s.top=0;
    memset(visit, 0, sizeof(visit));
    for (long long int i=0; i<N; i++) {
        dis[i]=INF;
    }
    dis[0]=0;
    s.data[s.top++]=0;
    visit[0]=1;
    while (s.top!=0) {
        now=s.data[--s.top];
        visit[now]=0;
        for (long long int i=pre[now]; i!=-1; i=eg[i].next) {
            if (dis[eg[i].fin]>dis[now]+eg[i].wt) {
                dis[eg[i].fin]=dis[now]+eg[i].wt;
                if (visit[eg[i].fin]==0) {
                    s.data[s.top++]=eg[i].fin;
                    visit[eg[i].fin]=1;
                }
            }
        }
    }
}


int main(int argc, const char * argv[]) {
    long long int a,b,c;
    cin >> N >> M ;
    memset(pre, -1, sizeof(pre));
    for (long long int i=0; i<M; i++) {
        scanf("%lld%lld%lld",&a,&b,&c);
        eg[i].fin=b-1;
        eg[i].wt=c;
        eg[i].next=pre[a-1];
        pre[a-1]=i;
    }
    spfa();
    cout << dis[N-1] << endl;
    return 0;
}

一个月后再次复习图论,看到这道题,想到卡STL的问题,于是用手写邻接表+STL的优先队列来了一发Dijkstra,还是过了,好像时间差的不是太多。


//
//  main.cpp
//  POJ-3159-Candies
//
//  Created by 袁子涵 on 15/12/2.
//  Copyright © 2015年 袁子涵. All rights reserved.
//
//  563ms   3172KB

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <stdlib.h>
#include <math.h>
#include <vector>
#include <queue>
#define INF 0x3f3f3f3f
#define MAXN 30005
#define MAXE 150005
using namespace std;
struct qnode
{
    int v,c;
    qnode(int _v=0,int _c=0):v(_v),c(_c){}
    bool operator <(const qnode &r)const
    {
        return c>r.c;
    }
};
struct Edge
{
    int v,cost,next;
    Edge(int _v=0,int _cost=0):v(_v),cost(_cost){}
};
Edge E[150005];
bool vis[MAXN];
int dist[MAXN],n,m,pre[MAXN];
void Dijkstra()
{
    memset(vis, 0, sizeof(vis));
    for (int i=1; i<=n; i++)    dist[i]=INF;
    priority_queue<qnode>que;
    while (!que.empty())    que.pop();
    dist[1]=0;
    que.push(qnode(1,0));
    qnode tmp;
    while (!que.empty()) {
        tmp=que.top();
        que.pop();
        int u=tmp.v;
        if(vis[u])continue;
        vis[u]=1;
        for (int i=pre[u]; i!=-1; i=E[i].next) {
            int v=E[i].v;
            int cost=E[i].cost;
            if (!vis[v] && dist[v]>dist[u]+cost) {
                dist[v]=dist[u]+cost;
                que.push(qnode(v,dist[v]));
            }
        }
    }
}
int main(int argc, const char * argv[]) {
    int a,b,c,now=1;
    cin >> n >> m;
    memset(pre, -1, sizeof(pre));
    for (int i=1; i<=m; i++) {
        scanf("%d%d%d",&a,&b,&c);
        E[now].v=b;
        E[now].cost=c;
        E[now++].next=pre[a];
        pre[a]=i;
    }
    Dijkstra();
    cout << dist[n] << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值