DP-HDU-1078-FatMouse and Cheese

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6778 Accepted Submission(s): 2787

Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output
37

Source
Zhejiang University Training Contest 2001

题意是一只胖老鼠,在一个n x n的网络中每个方格中都放了0到100个cheese,现在它要来吃东西了。
一开始它站在(0,0)的位置,并且可以向水平方向或者是垂直方向移动(注意这一点,二选一,不存在中途转弯的情况),并且由于有一只相爱相杀的猫在追它,它每次只能跑k个格子就得进洞,其实就是每次可以跑k格(上下左右四选一)。它在一格吃了该格的cheese后,会变得更胖,所以下一个目标格的cheese一定要更大一些(比较贪吃),现在求它在不能动之前,能够吃到的最多的cheese数量。
记忆DP(甚至可以说是DFS)。

//
//  main.cpp
//  基础DP1-P-FatMouse and Cheese
//
//  Created by 袁子涵 on 15/10/28.
//  Copyright © 2015年 袁子涵. All rights reserved.
//
//  140ms   2308KB

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>
#define MAX 200
#define maxof(a,b)  ((a)>(b)?(a):(b))
using namespace std;

int n,k;
long long int dp[MAX][MAX],cheese[MAX][MAX];
bool visit[MAX][MAX];

long long int DP(int x,int y,long long int c)
{
    if (cheese[x][y]<=c || x<1 || x>n || y<1 || y>n) {
        return 0;
    }
    if (visit[x][y]) {
        return dp[x][y];
    }
    dp[x][y]=cheese[x][y];
    for (int i=1; i<=k; i++) {
        dp[x][y]=maxof(DP(x-i,y,cheese[x][y])+cheese[x][y],dp[x][y]);
        dp[x][y]=maxof(DP(x+i,y,cheese[x][y])+cheese[x][y],dp[x][y]);
        dp[x][y]=maxof(DP(x,y+i,cheese[x][y])+cheese[x][y],dp[x][y]);
        dp[x][y]=maxof(DP(x,y-i,cheese[x][y])+cheese[x][y],dp[x][y]);
    }
    visit[x][y]=1;
    return dp[x][y];

}

int main(int argc, const char * argv[]) {
    while (scanf("%d%d",&n,&k)!=EOF && n!=-1 && k!=-1) {
        long long int out =0;
        memset(visit, 0, sizeof(visit));
        memset(dp, 0, sizeof(dp));
        for (int i=1; i<=n; i++) {
            for (int j=1; j<=n; j++) {
                scanf("%lld",&cheese[i][j]);
            }
        }
        out=DP(1, 1, 0);
        printf("%lld\n",out);

    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值