BZOJ-1620- [Usaco2008 Nov]Time Management 时间管理

Description

Ever the maturing businessman, Farmer John realizes that he must manage his time effectively. He has N jobs conveniently numbered 1..N (1 <= N <= 1,000) to accomplish (like milking the cows, cleaning the barn, mending the fences, and so on). To manage his time effectively, he has created a list of the jobs that must be finished. Job i requires a certain amount of time T_i (1 <= T_i <= 1,000) to complete and furthermore must be finished by time S_i (1 <= S_i <= 1,000,000). Farmer John starts his day at time t=0 and can only work on one job at a time until it is finished. Even a maturing businessman likes to sleep late; help Farmer John determine the latest he can start working and still finish all the jobs on time.

N个工作,每个工作其所需时间,及完成的Deadline,问要完成所有工作,最迟要什么时候开始.

Input

  • Line 1: A single integer: N

  • Lines 2..N+1: Line i+1 contains two space-separated integers: T_i and S_i
    Output

  • Line 1: The latest time Farmer John can start working or -1 if Farmer John cannot finish all the jobs on time.

Sample Input
4

3 5

8 14

5 20

1 16

INPUT DETAILS:

Farmer John has 4 jobs to do, which take 3, 8, 5, and 1 units of

time, respectively, and must be completed by time 5, 14, 20, and

16, respectively.

Sample Output
2

OUTPUT DETAILS:

Farmer John must start the first job at time 2. Then he can do

the second, fourth, and third jobs in that order to finish on time.


题解:
找到最晚的Deadline,然后从此时间向前推,每次选择当前剩余事件中Deadline最晚的。若是某次时间小于0便输出-1并停止,否则直到遍历完成后输出时间。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <string>
#include <queue>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;
int n;
typedef struct thing
{
    long long int t,s;
    bool operator <(const thing &r)const{return s>r.s;}
}thing;
vector<thing>Things;
int main()
{
    int nowtime,now=1;
    thing tmp;
    cin >> n;
    for(int i=0;i<n;i++)
    {
        cin >> tmp.t >> tmp.s;
        Things.push_back(tmp);
    }
    sort(Things.begin(),Things.end());
    tmp=Things[0];
    nowtime=tmp.s;
    for(int i=1;i<Things.size();i++)
    {
        if(nowtime>Things[i].s)
            nowtime=Things[i].s;
        nowtime-=Things[i].t;
        if(nowtime<0)
        {
            cout << -1 << endl;
            return 0;
        }
    }
    cout << nowtime << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值