Pie

Pie

题目地址

My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.
My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
—One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
—One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655

思路
pi 用 acos(-1.0);求不能直接用3.1415926,不然还是有误差 ;二分虽然可以接近答案,但绝对不如计算出来的准确,能用公式计算就用公式计算

①弄清二分对象

②二分停止条件。

③什么情况下应该记录二分循环过程的答案

④遇到死循环处理
    循环内输出 right left middle判断走向 因为二分指数爆炸增长,固定循环次数100 就是区间分长度缩小到2^100就完全够精度了。

⑤二分的 middle 的反复横跳的多种可能进行判断

⑥如果含答案为小数 则要尽可能使各种数据精确 ,约精确越好 left 和right 可以不考虑 -1,因为小数点后有很多位几位,可以到达边界 并且 左右边界很难重合所以要限制比较的位数和循环次数来防止死循环(left < right).

AC代码

#include <iostream>
#include <algorithm>
#include <iomanip>
#include <math.h>
using namespace std;
int main()
{
    int n;
    int N;
    int F;

    double pi = acos(-1.0);
    double r = 0;

    cin >> n;
    double num[10002];

    int sum = 0;
    double max,min;
    double middle,middle2;

    int count = 0;

    for(int i = 0;i < n;i++)
    {
        cin >> N >>F;
        for(int j = 0;j < N;j++)
        {
            cin >> r;
            num[j] = pow(r,2) * pi;
        }
        sort(num,num+N);
        max = num[N-1]+2;min = 0;
        middle = (max + min)/2;
        middle2 = middle;
        count = 0;
        while(max - min > 1e-6 && count < 100)
        {
            
            sum = 0;
            for(int j = 0;j < N;j++)
            {
                sum += num[j]/middle;
            }
            if(sum >=F+1)
            {
                min = middle;//double型可以到小数点后几位 边界可靠近
            }
            else
            {
                max = middle;
            }
            if(sum >= F+1)
            {
                   middle2 = middle;
            }
            middle = (max + min)/2;
           
            count ++;
        }
       
        cout << fixed << setprecision(4) ;
        cout << middle2 <<endl;
    }
    //system("pause");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值