题目-My birthday is coming up and traditionally I'm serving pie.

Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.<br><br>My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. <br><br>What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.<br>
 


Input
One line with a positive integer: the number of test cases. Then for each test case:<br>---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.<br>---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.<br>
 


Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 


Sample Input
 
 
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 


Sample Output
25.1317
3.1416
50.2655

解题思路:
你大概是不会理解的,,,,一个题明明知道思路,硬生生写了三遍,改了n遍,,,这大概就是理想与现实之间的差距。
题中没有说最小为多少,则从0开始,最大可以从饼中的最大或者是饼之和的平均值来选,二分法求,根据饼的切割块数判断区间的移动,
bug.1:精度没有控制好,变成了死循环;
bug.2:预设了一个存放最大饼的体积的变量,每次用完之后没有清零,卒。。
bug....n:包括将cin改成scanf,,改变区间移动的判断方式,,都没什么卵用,,最后将pi=3.1415926改成了pi=acos(-1.0),,然后就过了,,过了,,
ac.1:
#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
double a[10001],pi=acos(-1.0);
int f,n;
int dao(double size)
{
    int sum=0;
    for(int i=1;i<=n;i++)
    {
        sum+=int(a[i]/size);
    }
    if(sum>=f+1)return 1;
    else return 0;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
//cout<<"-------------------------------------------------------------------------"<<endl;
        double low,high,mid,ans=-1,v=0;//,max=-1
        scanf("%d%d",&n,&f);
        for(int i=1;i<=n;i++)
        {
            scanf("%lf",&a[i]);
            a[i]=a[i]*a[i]*pi;
            v+=a[i];
            //if(a[i]>max)max=a[i];
        }
        low=0;
        high=v/(f+1);
        while(high-low>0.000001)
        {
            mid=(high+low)/2;
//cout<<"low="<<low<<"  mid="<<mid<<"  high="<<high<<endl<<"dao(mid)="<<dao(mid)<<"  f+1="<<f+1<<endl;
            if(dao(mid))
            {
                low=mid;
                //if(mid>ans){ans=mid;}
            }
            else high=mid;
//cout<<"ans="<<ans<<endl<<endl;
        }
        printf("%.4lf\n",mid);
    }
    return 0;
}


  • 3
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值