LightOJ_1106 Gone Fishing

Description

John is going on a fishing trip. He has h hours available, and there are n lakes in the area all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i (1 to n-1), the number of 5-minute intervals it takes to travel from lake i to lake i+1 is denoted ti. For example, t3=4 means that it takes 20 minutes to travel from lake 3 to 4.

To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi, is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di. If the number of fish expected to be caught in an interval is less than or equal to di, there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch. Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing two integers n (2 ≤ n ≤ 25) and h (1 ≤ h ≤ 16). Next, there is a line of n integers specifying fi (0 ≤ fi ≤ 1000), then a line of n integers di (0 ≤ di ≤1000), and finally, a line of n-1 integers denoting ti (0 < ti < 192).

Output

For each test case, print the case number first. Then print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught. This is followed by a line containing the number of fish expected. If multiple plans exist, choose the one that spends as long as possible at lake 1. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on.

Sample Input

3

2 1

10 1

2 5

2

4 4

10 15 20 17

0 3 4 3

1 2 3

4 4

10 15 50 30

0 3 4 3

1 2 3

Sample Output

Case 1:

45, 5

Number of fish expected: 31

Case 2:

240, 0, 0, 0

Number of fish expected: 480

Case 3:

115, 10, 50, 35

Number of fish expected: 724


题目分析:

        约翰在第 pos 个湖结束钓鱼,用于钓鱼的时间是 time (不含路程),即钓鱼time次。可以采用贪心的策略来构造约翰的钓鱼计划。可以认为约翰具有 “瞬间转移 ” 的功能,即在任意一个时刻都可以从任意两个湖间穿梭。

代码:

#include<string.h>
#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iomanip>
#include<ctime>
#include<cstdio>
#include<stack>
#include<map>
#include<queue>
#include<vector>
#include<cctype>
using namespace std;
int fi[50],di[50],ti[50];
int plan[50];

int main()
{
    int kcase=1;
    int tt;
    scanf("%d",&tt);
    while(tt--)
    {
        int N,H;
        scanf("%d%d",&N,&H);
        H=H*12;
        for(int i=0;i<N;i++)
        {
            scanf("%d",&fi[i]);
        }
        for(int i=0;i<N;i++)
        {
            scanf("%d",&di[i]);
        }
        for(int i=0;i<N-1;i++)
        {
            scanf("%d",&ti[i]);
        }
        
        int ans=0;
        for(int i=0;i<N;i++)     //枚举最远所能到达的湖的编号
        {
            int tempans=0;
            int hh=H;
            for(int j=0;j<=i-1;j++)
            {
                hh-=ti[j];
            }
            if(hh<=0)
            {
                break;
            }
            
            int tempplan[50];
            memset(tempplan,0,sizeof(tempplan));
            int tempfi[50];
            for(int j=0;j<N;j++)
            {
                tempfi[j]=fi[j];
            }
            
            int maxx=0;
            int pos;
            while(hh>0)
            {    
                maxx=0;            
                for(int j=0;j<=i;j++)
                {
                    if(tempfi[j]>maxx)
                    {
                        maxx=tempfi[j];
                        pos=j;
                    }
                }
                if(maxx>0)
                {
                    tempans+=maxx;
                    tempplan[pos]++;
                    tempfi[pos]-=di[pos];
                }
                else
                {
                    break;
                }
                hh--;         //当某个 di 等于 0 时,若不加这个条件就会陷入死循环            
            }
            if(tempans>ans)
            {
                ans=tempans;
                if(hh>0)
                {
                    tempplan[0]+=hh;
                }
                for(int j=0;j<N;j++)
                {
                    plan[j]=tempplan[j];
                }            
            }            
        }                    
        printf("Case %d:\n",kcase++);
        printf("%d",plan[0]*5);
        for(int i=1;i<N;i++)
        {
            printf(", %d",plan[i]*5);
        }
        cout<<endl;
        cout<<"Number of fish expected: "<<ans<<endl;        
    }    
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值