A1033 To Fill or Not to Fill (25分)【C语言】

A1033 To Fill or Not to Fill (25分)【C语言】

原题链接

晴神…

题目描述:
With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

输入格式:
Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​ , the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

输出格式:
For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

输入样例1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

输出样例1:

749.17

输入样例2:

50 1300 12 2
7.10 0
7.00 600

输出样例2:

The maximum travel distance = 1200.00

实现代码:

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 510;
const int INF = 1000000000;
struct station{
	double price;
	double dis;
}st[maxn];

bool cmp(station a, station b){
	return a.dis<b.dis;
}

int main()
{
	int n, i;
	double Cmax, D, Davg;
	scanf("%lf %lf %lf %d", &Cmax, &D, &Davg, &n);
	for(i=0; i<n; ++i){
		scanf("%lf %lf", &st[i].price, &st[i].dis);
	}
	st[n].price = 0; //终点价格为0 
	st[n].dis = D; //终点距离为D
	sort(st, st+n, cmp);
	if(st[0].dis!=0){ //因为油箱初始值为0,因此如果第一个加油站的距离不是0的话,就无法出发 
		printf("The maximum travel distance = 0.00\n");
	}else{
		int now=0; //当前加油站编号
		double ans=0, nowTank=0, MAX=Cmax*Davg; //总花费,油箱中剩余油量,满油行驶距离
		while(now<n){
		/*每次循环选出下一个需要到达的加油站
		选择当前加油站满油能到达范围内的第一个油价低于当前油价的加油站
		如果没有低于当前油价的加油站,则选择能到达范围内价格最低的那个*/
		int k = -1; //最低油价的加油站编号
		double minPrice = INF; //最低油价
		for(i=now+1; i<=n && st[i].dis-st[now].dis<=MAX; ++i){
			if(st[i].price<minPrice){ //油价比当前最低油价低,更新最低油价 
				minPrice = st[i].price;
				k = i;
				if(minPrice<st[now].price){ //找到第一个油价低于当前油价的加油站,直接中断循环 
					break;
				}
			}
		}
		if(k==-1) break; //满油状态下无法找到加油站,跳出循环
		//下面为能找到可到达的加油站k,计算转移花费 
		double need = (st[k].dis-st[now].dis) / Davg; //now到k所需油量
		if(minPrice<st[now].price){ //如果加油站k的油价低于当前油价,只买足够到达k加油站的油量即可 
			if(nowTank<need){ //如果当前油量不足need 
				ans += (need-nowTank) * st[now].price; //补足need 
				nowTank = 0; //到达加油站k后剩余油量为0 
			}else{
				nowTank -= need; //剩余油量超过need,直接到达加油站k 
			} 
		}else{ //加油站k油价高于当前油价,即现在将油箱加满 
			ans += (Cmax-nowTank) *st[now].price;
			nowTank = Cmax - need; //到达加油站k后的剩余油量 
		}
		now = k; //到达加油站k,进入下一次循环 
		}
		if(now==n){ //能到达终点 
			printf("%.2f\n", ans);
		}else{ //不能到达终点 
			printf("The maximum travel distance = %.2f\n", st[now].dis+MAX);
		}
	}

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值