A1029 Median (25分)【C语言】

A1029 Median (25分)【C语言】

原题链接

题目描述:
Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

输入格式:
Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10 ​5​​ ) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

输出格式:
For each test case you should output the median of the two given sequences in a line.

输入样例:

4 11 12 13 14
5 9 10 15 16 17

输出样例:

13

实现代码:

#include <cstdio>
const int maxn = 200010;
const int INF = 0x7fffffff; //int取值范围的最大值(2^31-1)
int S1[maxn], S2[maxn];

int main()
{
	int n, m;
	scanf("%d", &n);
	for(int i=0; i<n; ++i){
		scanf("%d", &S1[i]);
	}
	scanf("%d", &m);
	for(int i=0; i<m; ++i){
		scanf("%d", &S2[i]);
	}
	S1[n] = S2[m] = INF; 
	//当一个序列已经扫描完,但count还未到中位数位置的时候,定一个上限解决越界问题 
	int medianPos = (m+n-1)/2;
	int i=0, j=0, count=0;
	while(count<medianPos){
		if(S1[i]<S2[j]) i++;
		else j++;
		count++;
	}
	//上述while循环中,确定新序列0号位置时,count计数为1
	//因此当count到中位数位置时,还未确定中位数的值,因此选择S1[i]与S2[j]中较小的数输出 
	if(S1[i]<S2[j]){
		printf("%d", S1[i]);
	}else{
		printf("%d", S2[j]);
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值