A1051 Pop Sequence (25分)【C语言】

A1051 Pop Sequence (25分)【C语言】

原题链接

模拟真实入栈、出栈来判断题中所给出栈序列是否正确

题目描述:
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

输入格式:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

输出格式:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

输入样例:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

输出样例:

YES
NO
NO
YES
NO

实现代码:

#include <cstdio>
#include <stack>
using namespace std;
const int maxn = 1010;
int arr[maxn]; //题目中给出的出栈序列
stack<int> st; //栈st,存放int型数据 

int main()
{
	int m, n, k;
	scanf("%d%d%d", &m, &n, &k); 
	while(k--){
		while(!st.empty()){ //清空栈 
			st.pop();
		}
		for(int i=1; i<=n; ++i){
			scanf("%d", &arr[i]);
		}
		int current = 1; //标记现在出栈序列中等待出栈的元素下标 
		bool flag = true; //标记出栈序列是否正确 
		for(int i=1; i<=n; ++i){
			st.push(i);
			if(st.size()>m){ //如果当前入栈元素超过栈的大小,则直接判断出栈序列不正确 
				flag = false;
				break;
			}
			while(!st.empty() &&st.top()==arr[current]){ //出栈前必须判断栈是否为空 
				//栈顶元素与当前等待出栈元素相同时出栈
				st.pop();
				current++; //等待出栈元素向后移 
			}
		}
		if(st.empty() && flag){ //如果栈空且标记正确 
			printf("YES\n");
		}else{
			printf("NO\n");
		}
	}
	
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值