(poj 1986 Distance Queries)<LCA—tarjan>

题目

Distance Queries

Time Limit: 2000MS
Memory Limit: 30000K

Description

Farmer John’s cows refused to run in his marathon since he chose a path much too long for their leisurely lifestyle. He therefore wants to find a path of a more reasonable length. The input to this problem consists of the same input as in “Navigation Nightmare”,followed by a line containing a single integer K, followed by K “distance queries”. Each distance query is a line of input containing two integers, giving the numbers of two farms between which FJ is interested in computing distance (measured in the length of the roads along the path between the two farms). Please answer FJ’s distance queries as quickly as possible!

Input

Lines 1..1+M: Same format as “Navigation Nightmare”

Line 2+M: A single integer, K. 1 <= K <= 10,000

Lines 3+M..2+M+K: Each line corresponds to a distance query and contains the indices of two farms.

Output

Lines 1..K: For each distance query, output on a single line an integer giving the appropriate distance.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6
1 4
2 6

Sample Output

13
3
36

直接忽略字母

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

const int MAXN=40010;
int n,m,k;
struct node{
    int to,nxt,val;
}e[MAXN*2],E[MAXN*2];
int head[MAXN],head2[MAXN];
int cnt,tot;
bool vis[MAXN];
int f[MAXN];
int dis[MAXN];
int ans[MAXN];

int _find(int x){
    if(f[x]==-1) return x;
    f[x]=_find(f[x]);
    return f[x];
}

void add(int f,int t,int v){
    cnt++;
    e[cnt].to=t;
    e[cnt].nxt=head[f];
    e[cnt].val=v;
    head[f]=cnt;
}

void add_edge(int f,int t,int i){
    tot++;
    E[tot].to=t;
    E[tot].nxt=head2[f];
    E[tot].val=i;
    head2[f]=tot;
}

void tarjan(int u){
    vis[u]=1;
    for(int i=head[u];i!=-1;i=e[i].nxt){
        int v=e[i].to;
        if(!vis[v]){
            dis[v]=dis[u]+e[i].val;
            tarjan(v);
            f[v]=u;
        }
    }
    for(int i=head2[u];i!=-1;i=E[i].nxt){
        int v=E[i].to;
        int num=E[i].val;
        if(vis[v]){
            ans[num]=dis[v]+dis[u]-2*dis[_find(v)];
        }
    }
}

int main(){
    memset(f,-1,sizeof(f));// !!!
    memset(head,-1,sizeof(head));
    memset(head2,-1,sizeof(head2));
    scanf("%d%d",&n,&m);
    int a,b,c;
    char r;
    for(int i=1;i<=m;++i){
        scanf("%d%d%d",&a,&b,&c);
        scanf("%c",&r);
        scanf("%c",&r);
        add(a,b,c);add(b,a,c);
    }
    scanf("%d",&k);
    for(int i=1;i<=k;++i){
        scanf("%d%d",&a,&b);
        add_edge(a,b,i);add_edge(b,a,i);
    }
    tarjan(1);
    for(int i=1;i<=k;i++)
        printf("%d\n",ans[i]);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值