(hdu 2588 gcd)<数论—欧拉函数>

题目

Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

Output
For each test case,output the answer on a single line.

Sample Input
3
1 1
10 2
10000 72

Sample Output
1
6
260

题目的大致意思是:给定n和m,求在所有小于n的正整数中,有几个和n的gcd大于等于m。多组数据

题解

     - 如果gcd(a,b)=c   那么gcd(a/c,b/c)=1
     - 此时求的是对于一个数x,首先它要大于m,那么只需要gcd(n,x*q)=x,q是正整数且x*q<=n
     - gcd(n,x*q)=x等价于gcd(n/x,q)=1
     - 因此只需要用欧拉函数算出与n/x互质的数有多少即可,同时可以避免重复

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int T;
int n,m;
int ans;

int euler(int x){//计算某个数的欧拉函数值
    int tmp=1,i;
    for(i=2;i*i<=x;i++)
    {
        if(x%i==0)
        {
            x/=i;tmp*=i-1;
            while(x%i==0)
            {x/=i;tmp*=i;}
        }
    }
    if(x>1)
    tmp*=x-1;
    return tmp;
}

int main(){
    scanf("%d",&T);
    while(T--){
        ans=0;
        scanf("%d%d",&n,&m);
        for(int i=1;i*i<=n;++i){
            if(n%i==0){
                if(i>=m) ans+=euler(n/i);
                if(i*i!=n&&n/i>=m) ans+=euler(i);//两步一起写可以少循环。i*i!=n 用于判重
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值