Big Event in HDU HDU - 1171 (多重背包)

Big Event in HDU

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002. 
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds). 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different. 
A test case starting with a negative integer terminates input and this test case is not to be processed. 

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2
10 1
20 1
3
10 1 
20 2
30 1
-1

Sample Output

20 10
40 40

题意: 

两个学院分配设备,每个设备价值是v,有m件,要求每个学院分配到的设备的总价值都更平均,更接近。

所以可以先求出所有设备的总价值,然后既然是要两个学院的设备价值更接近,那么有一个学院的价值肯定是≤(总价值/2)。剩余的就是另一个学院的。

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxn=5007;
int v[maxn];
int m[maxn];
int dp[251007];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF&&n>0)
	{
		int sum=0,sumv;
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&v[i],&m[i]);
			sum+=v[i]*m[i];              //所有设备的总价值 
		}
		sumv=sum/2;    //一个学院所分到的价值最接近但不能超过价值的一半 
		for(int i=1;i<=n;i++)
		{
			for(int k=1;k<=m[i];k++)
			{
				for(int j=sumv;j>=v[i];j--)
				{
					dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
				}
			}
		}
		int a=dp[sumv]>(sum-dp[sumv])?dp[sumv]:(sum-dp[sumv]);   //a要大于b,所以要取大的值 
		int b=sum-a;
		printf("%d %d\n",a,b);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值