Prime Ring Problem HDU - 1016 ( 搜索DFS )

Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

Input

n (0 < n < 20). 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 

Sample Input

6
8                                                                                                                                                                                                     

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题意:

将n个数来放到n个位置上,相邻的两个数和一定要是素数,输出符合的序列,序列一定要是从1为开头。

放第n个数时,要记得和第一个数进行判断和是否为素数

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n;
int vis[27];  //vis数组用来标记数是否用了
int num[27];  //num来存放序列
int cnt=0;
int isp(int x)  //判断素数
{
	for(int i=2;i*i<=x;i++)
	{
		if(x%i==0)
		 return 0;
	}
	return 1;
}
void dfs(int step)
{
     //如果step=n说明n个数都找到,然后要判断最后一个数和第一个数的和是否符合素数
	if(step==n&&isp(num[0]+num[step-1])==1) 	
    {
		printf("%d",num[0]);
		for(int i=1;i<n;i++)
		 printf(" %d",num[i]);
		printf("\n");
		return ;
	}
	for(int i=2;i<=n;i++)
	{ 
		if(vis[i]==0&&isp(i+num[step-1])==1)
		{ 
			num[step]=i;
			vis[i]=1;
			dfs(step+1);
			vis[i]=0;
		}
	}
}
int main()
{
	
	num[0]=1;  //第一个数永远是1
	while(scanf("%d",&n)!=EOF)
	{
		memset(vis,0,sizeof(vis));  
		cnt++;
		printf("Case %d:\n",cnt);
		dfs(1);
		printf("\n");
	} 
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值