Robberies HDU - 2955 ( 0-1背包 )

Robberies

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible. 


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. 

Notes and Constraints 
0 < T <= 100 
0.0 <= P <= 1.0 
0 < N <= 100 
0 < Mj <= 100 
0.0 <= Pj <= 1.0 
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

题意:

先给出测试样例的个数t,每个测试样例第一行是总被抓概率P(最后求得的总概率必须小于他,否则就会被抓),然后是想抢的银行数n。然后n行,每行分别是该银行能抢的钱数m和被抓的概率p。求不被抓到的概率内可抢到的最大的金钱数

因为题目给出的是被抓的概率,那么我们就转换为安全概率1-p,然后使用0-1背包。dp[i]就是抢到钱数是i时候的安全概率。最后求出不超过总安全概率(1-P)的最多的i数。

代码:

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<algorithm>
using namespace std;
double dp[105*105];
struct node{
	int money;  //钱数 
	double p;   //安全的概率 
}bank[110];
int main()
{
	int t,n;
	double P;
	scanf("%d",&t);
	while(t--)
	{
		int m=0;
		scanf("%lf%d",&P,&n);  //被抓的概率,n个银行 
		P=1.0-P; //安全概率 
		for(int i=1;i<=n;i++)
		{
			scanf("%d%lf",&bank[i].money,&bank[i].p);
			bank[i].p=1.0-bank[i].p;
			m+=bank[i].money;   //所有银行钱 
		}
		memset(dp,0,sizeof(dp));
		dp[0]=1; //不抢的时候,安全概率是1 
		for(int i=1;i<=n;i++)
		{
			for(int j=m;j>=bank[i].money;j--)
			{
				dp[j]=max(dp[j],dp[j-bank[i].money]*bank[i].p);//dp[j]:抢到j钱的安全概率 
			}
		}
		for(int i=m;i>=0;i--)
		{
			if(dp[i]>P)
			{
				printf("%d\n",i);
				break;
			}
		} 
	}
	return 0;
 }  

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值