[蓝桥杯题解] 7-14 词频统计 (30 分)

请编写程序,对一段英文文本,统计其中所有不同单词的个数,以及词频最大的前10%的单词。

所谓“单词”,是指由不超过80个单词字符组成的连续字符串,但长度超过15的单词将只截取保留前15个单词字符。而合法的“单词字符”为大小写字母、数字和下划线,其它字符均认为是单词分隔符。

输入格式:

输入给出一段非空文本,最后以符号#结尾。输入保证存在至少10个不同的单词。

输出格式:

在第一行中输出文本中所有不同单词的个数。注意“单词”不区分英文大小写,例如“PAT”和“pat”被认为是同一个单词。

随后按照词频递减的顺序,按照词频:单词的格式输出词频最大的前10%的单词。若有并列,则按递增字典序输出。

输入样例:

This is a test.

The word "this" is the word with the highest frequency.

Longlonglonglongword should be cut off, so is considered as the same as longlonglonglonee.  But this_8 is different than this, and this, and this...#
this line should be ignored.
 

输出样例:(注意:虽然单词the也出现了4次,但因为我们只要输出前10%(即23个单词中的前2个)单词,而按照字母序,the排第3位,所以不输出。)

23
5:this
4:is

这个题开始想的特别复杂,一上来就拿字典树写。但是这肯定就是特别特别麻烦,然后看别人用的map直接存,这多方便!

除了我    别人都是聪明的... 

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include<iterator>
#include<vector> 
using namespace std;
map<string,int> dict;
struct node{
	string str;
	int num;
};
struct node nod;
bool cmp(struct node a,struct node b)
{
	if(a.num>b.num)return true;
	else if(a.num==b.num)return a.str<b.str;
	else return false;
}
int main()
{
	char c;
	string str; 
	while(scanf("%c",&c)!=EOF)
	{
		if((c>='a'&&c<='z')||(c>='0'&&c<='9')||(c>='A'&&c<='Z')||(c=='_'))
		{
			if(c>='A'&&c<='Z') //将大写字母转换为小写
			{
			   c=c-'A'+'a';
			}
			if(str.length()<15) //只要没超过15个字母这个单词就可以继续存
			{
				str+=c;
			}
		}
		else if(c=='#'||str.length()>0)
		{
			if(!dict[str]){  //如果map不存在这个单词
				dict[str]=1;
			}
			else{            //map已经存了这个单词
				dict[str]++;
			}
			str.clear();
			if(c=='#')break;
		}
	}
	map<string,int>::iterator it; 
	vector<node> v;
    //将存到map中的单词拿出来放到vector中,便于排序输出出现次数多的单词。
	for(it=dict.begin();it!=dict.end();it++)
	{
		if(it->first.length()>0)
		{
			nod.str=it->first;
			nod.num=it->second;
			v.push_back(nod); 
		}
	}
	sort(v.begin(),v.end(),cmp); //排序
	int count=v.size()*0.1;
	cout<<v.size()<<endl;
	for(int i=0;i<count;i++)
	{
		cout<<v[i].num<<":"<<v[i].str<<endl;
	}
}

 

  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值