总时间限制:
1000ms
内存限制:
65536kB
描述
若一个顺序表L,其中所有的元素为正整数。设计一个程序,删除元素值在[x,y]之间的所有元素后输出该顺序表。注意保持元素顺序不变。
输入
三行数据。
第一行是顺序表的元素个数(不超过20),第二行是顺序表的元素(空格隔开),第三行是x和y。
输出
删除元素值在[x,y]之间的所有元素后的顺序表。空格隔开
样例输入
105 1 9 10 67 12 8 33 6 23 10
样例输出
1 67 12 33 2
#include <stdio.h>
#include <stdlib.h>
#define OK 1
#define ERROR 0
#define OVERFLOW -2
#define _CRT_SECURE_NO_WARNING
#define LIST_INIT_SIZE 100 //线性表储存空间的初始分配量
#define LISTINCREMENT 10 //线性表储存空间的分配增量
typedef int ElemType;
typedef struct {
ElemType *elem; //储存空间基址
int length; //当前长度
int listsize; //当前分配的存储量(以sizeof(ElemType)为单位)
}SqList;
int InitList_Sq(SqList *L) {
L->elem = (ElemType *)malloc(LIST_INIT_SIZE * sizeof(ElemType));
if (!L->elem) exit(OVERFLOW); //储存分配失败
L->length = 0; //空表长度为0
L->listsize = LIST_INIT_SIZE; //初始储存容量
return OK;
}
int ListInsert_Sq(SqList *L, int i, ElemType e) { //在顺序线性表L中第i个位置之前插入新的元素e,
ElemType *p, *q; //i的合法值为1<=i<=ListLength_Sq(L)+1
if (i<1 || i>L->length + 1) return ERROR; //i值不合法
if (L->length >= L->listsize) { //当前储存空间已满,增加分配
ElemType *newbase = (ElemType *)realloc(L->elem,
(L->listsize + LISTINCREMENT) * sizeof(ElemType));
if (!newbase) return ERROR; //储存分配失败
L->elem = newbase; //新基址
L->listsize += LISTINCREMENT; //增加存储容量
}
q = &(L->elem[i - 1]); //q为插入位置
for (p = &(L->elem[L->length - 1]); p >= q; --p) *(p + 1) = *p; //插入位置及之后的元素右移
*q = e; //插入e
++L->length; //表长增1
return OK;
}
int main(void) {
int i = 0;
int m, n, k=0,o=0;
SqList LA;
InitList_Sq(&LA);
scanf("%d", &m);
LA.length =m;
for (i = 0;i<m; i++) {
scanf("%d", &LA.elem[i]);
}
scanf("%d %d",&n,&k);
for(i=0;i<m-1;i++){
if(LA.elem[i]<n||LA.elem[i]>k)
printf("%d ",LA.elem[i]);
}
if(LA.elem[i]<n||LA.elem[i]>k)
printf("%d\n",LA.elem[i]);
return 0;
}
<stdio.h>
#include <stdlib.h>
#define OK 1
#define ERROR 0
#define OVERFLOW -2
#define _CRT_SECURE_NO_WARNING
#define LIST_INIT_SIZE 100 //线性表储存空间的初始分配量
#define LISTINCREMENT 10 //线性表储存空间的分配增量
typedef int ElemType;
typedef struct {
ElemType *elem; //储存空间基址
int length; //当前长度
int listsize; //当前分配的存储量(以sizeof(ElemType)为单位)
}SqList;
int InitList_Sq(SqList *L) {
L->elem = (ElemType *)malloc(LIST_INIT_SIZE * sizeof(ElemType));
if (!L->elem) exit(OVERFLOW); //储存分配失败
L->length = 0; //空表长度为0
L->listsize = LIST_INIT_SIZE; //初始储存容量
return OK;
}
int ListInsert_Sq(SqList *L, int i, ElemType e) { //在顺序线性表L中第i个位置之前插入新的元素e,
ElemType *p, *q; //i的合法值为1<=i<=ListLength_Sq(L)+1
if (i<1 || i>L->length + 1) return ERROR; //i值不合法
if (L->length >= L->listsize) { //当前储存空间已满,增加分配
ElemType *newbase = (ElemType *)realloc(L->elem,
(L->listsize + LISTINCREMENT) * sizeof(ElemType));
if (!newbase) return ERROR; //储存分配失败
L->elem = newbase; //新基址
L->listsize += LISTINCREMENT; //增加存储容量
}
q = &(L->elem[i - 1]); //q为插入位置
for (p = &(L->elem[L->length - 1]); p >= q; --p) *(p + 1) = *p; //插入位置及之后的元素右移
*q = e; //插入e
++L->length; //表长增1
return OK;
}
int main(void) {
int i = 0;
int m, n, k=0,o=0;
SqList LA;
InitList_Sq(&LA);
scanf("%d", &m);
LA.length =m;
for (i = 0;i<m; i++) {
scanf("%d", &LA.elem[i]);
}
scanf("%d %d",&n,&k);
for(i=0;i<m-1;i++){
if(LA.elem[i]<n||LA.elem[i]>k)
printf("%d ",LA.elem[i]);
}
if(LA.elem[i]<n||LA.elem[i]>k)
printf("%d\n",LA.elem[i]);
return 0;
}