poj2823 Sliding Window

传送门
Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1 3 -1] -3 5 3 6 7 -1 3
1 [3 -1 -3] 5 3 6 7 -3 3
1 3 [-1 -3 5] 3 6 7 -3 5
1 3 -1 [-3 5 3] 6 7 -3 5
1 3 -1 -3 [5 3 6] 7 3 6
1 3 -1 -3 5 [3 6 7] 3 7
Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.
Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.
Sample Input

8 3
1 3 -1 -3 5 3 6 7
Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7
Source

POJ Monthly–2006.04.28, Ikki

题解

题意:给你n个数,让你在每个长度为k的区间内查找最大值和最小值。
单调队列大裸题(RMQ应该也可以?不知道会不会TLE)
没什么好说的。注意自己的队首指针位置,判断时不要用错元素(用到队首前一个空位置的元素)
吐槽:为什么在poj上不加读入优化比加了读入优化还快QAQ

CODE:

#include<cstdio>
const int N=1e6+10;
struct node
{
    int x,y;
}x[N],y[N],tmp;
int ans[N][2];
int n,k,h1,t1,h2,t2,num;
int main()
{
    scanf("%d%d",&n,&k);
    for(int i=1;i<=k;i++)
    {
        scanf("%d",&num);
        tmp.x=num,tmp.y=i;
        while(t1>h1&&num>x[t1].x) t1--;
        x[++t1]=tmp;
        while(t2>h2&&num<y[t2].x) t2--;
        y[++t2]=tmp;
    }
    ans[k][0]=x[h1+1].x,ans[k][1]=y[h2+1].x;
    for(int i=k+1;i<=n;i++)
    {
        scanf("%d",&num);
        tmp.x=num,tmp.y=i;
        if(i-x[h1+1].y==k) h1++;
        while(t1>h1&&num>x[t1].x) t1--;
        x[++t1]=tmp;
        if(i-y[h2+1].y==k) h2++;
        while(t2>h2&&num<y[t2].x) t2--;
        y[++t2]=tmp;
        ans[i][0]=x[h1+1].x,ans[i][1]=y[h2+1].x;
    }
    for(int i=k;i<=n;i++)
      printf("%d ",ans[i][1]);
    printf("\n");
    for(int i=k;i<=n;i++)
      printf("%d ",ans[i][0]);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值