【贪心算法】Monkeys and Bananas

Problem Description

Given an array of size n that has the following specifications:
Each element in the array contains either a monkey or a banana.
Each monkey can eat only one banana.
A monkey cannot eat a banana which is more than K units away from the monkey.
We need to find the maximum number of bananas that can be eaten by monkeys.

Input

Two lines.
The first line contains an array of size n contain chars ‘B’ (represent Banana) or ‘M’ (represent Monkey). n >= 0.
The second line contains a integer K, K >= 0.

Output

An integer, the maximum number of bananas can be eaten by monkeys.

Sample Input

MBBMB
1

Sample Output

2

原题地址:

UOJ#52

#include <iostream>
#include <cstring>
#include <vector>
using namespace std;
class Solution {
public:
    int maxBananas(int k, vector<char>& arr){
        if (k == 0)     // 若猴子可以吃到香蕉的范围为0,则直接返回0个即可
            return 0;
        n = arr.size();
        for(int i = 0;i < n;i++){
            if(arr[i] == 'M'){
                // 观察该猴子以k为半径从左数第k个到右数第k个,是否有香蕉,有则计数,并抹去对于索引的香蕉
                for(int j = -k;j <= k;j++)
                    if((i + j >= 0) && (arr[i + j] == 'B')){
                        arr[i+j] = '0';
                        maxCnt ++;
                        break;  // 只要吃到,就跳出循环,因为每个猴子最多只能吃一个香蕉
                    }
            }
        }
        return maxCnt;
    }
private:
    int n, maxCnt = 0;  // n数组长度,maxCnt所有猴子吃到最多的香蕉个数
};
int main(){
    int k;
    char element;
    vector<char> arr;
    while (cin.peek()!='\n'){
        cin >> element;
        arr.push_back(element);
    }
    cin >> k;
    Solution sol;
    cout<<sol.maxBananas(k, arr)<<endl;
    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

SL_World

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值