(poj3263) Tallest Cow

Tallest Cow

Description

FJ’s N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.

FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form “cow 17 sees cow 34”. This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.

For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

Input

Line 1: Four space-separated integers: N, I, H and R
Lines 2..R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.

Output

Lines 1..N: Line i contains the maximum possible height of cow i.

Sample Input

9 3 5 5
1 3
5 3
4 3
3 7
9 8

Sample Output

5
4
5
3
4
4
5
5
5

Source

USACO 2007 January Silver

非正经翻译:

   古有一奇人,名曰农夫约翰(Farmmer John),自名为FJ(f****ob?AJの肉親?此,无可告知)┑( ̄Д  ̄)┍
   FJ有N牛于棚,现牛并驾。两牛互视,直视无碍。故两牛之间,无俞高之牛也。(๑•̀ㅂ•́)و✧
   今昔人知,最高之牛P,其高约H。不知余牛之高,但知直视之关系。每队关系,知Ai与Bi可直视。( ̄_, ̄ )
   现今,邀汝求各牛所高之巨,何为?ヾ( ̄▽ ̄)

题解:

   本题为前缀和;
   设数组c[i]储存i牛和p牛身高的差距,换言之,i牛的身高就等于h+c[i]。由题可得a,b之间的牛都没a,b高,所以在a,b之间的牛至少要比a,b小1。便可用for循环,把c[a+1~b-1]都-1(可以设a

#include <cstdio>
#include <algorithm>
#include <map>
using namespace std;
int n,m,p,h,x;
int c[10010],d[10010];
bool r[10010][10010];

int main()
{
    scanf("%d%d%d%d",&n,&p,&h,&m);
    for (int i=1; i<=m; i++){
        int a,b;
        scanf("%d%d",&a,&b);
        if (a>b) swap(a,b);
        if (not(r[a][b])){//去重
            d[a+1]--; d[b]++;
            r[a][b]=not(r[a][b]);
        }
    }
    for (int i=1;i <= n; i++){
        c[i]=c[i-1]+d[i];
        printf("%d\n",h+c[i]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值