hdu 4965 Fast Matrix Calculation(矩阵乘法)

Problem Description
One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her.

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation.

Step 1: Calculate a new N*N matrix C = A*B.
Step 2: Calculate M = C^(N*N). 
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’.
Step 4: Calculate the sum of all the elements in M’. 

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.
 

Input
The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B.

The end of input is indicated by N = K = 0.
 

Output
For each case, output the sum of all the elements in M’ in a line.
 

Sample Input
  
  
4 2 5 5 4 4 5 4 0 0 4 2 5 5 1 3 1 5 6 3 1 2 3 0 3 0 2 3 4 4 3 2 2 5 5 0 5 0 3 4 5 1 1 0 5 3 2 3 3 2 3 1 5 4 5 2 0 0
 

Sample Output
  
  
14 56
 

Author
SYSU
 

Source

让求a*b的n*n次方,a是[n,k]的矩阵,b是[k,n]的矩阵,n是1000,k只有6,但是a*b的矩阵就是1000*1000的了,再来个n*n次方,肯定超时,所以我们可以把公式转换一下:

(a*b)^(n*n) == a*(b*a)*(b*a)*....*(b*a)*b   == a*(b*a)^(n*n-1)*b

这样就是求一个6*6矩阵的n*n-1次方,这样就不会超时了。


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define LL long long
using namespace std;

const int mod = 6;

struct Matrix
{
    long long m[6][6];
    int n;
    Matrix(int x)
    {
        n = x;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                m[i][j] = 0;
    }
    Matrix(int _n,int a[10][10])
    {
        n = _n;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
            {
                m[i][j] = a[i][j];
            }
    }
};
Matrix operator *(Matrix a,Matrix b)
{
    int n = a.n;
    Matrix ans = Matrix(n);
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
            for(int k=0;k<n;k++)
            {
                ans.m[i][j] += (a.m[i][k]%mod)*(b.m[k][j]%mod)%mod;
                ans.m[i][j] %= mod;
            }
    return ans;
}
Matrix operator ^(Matrix a,int k)
{
    int n = a.n;
    Matrix c(n);
    int i,j;
    for(i=0;i<n;i++)
        for(j=0;j<n;j++)
            c.m[i][j] = (i==j);
    for(;k;k>>=1)
    {
        if(k&1)
            c=c*a;
        a = a*a;
    }
    return c;
}

int a[1000][6],b[6][1100],c[6][6];
int ac[1000][6];
int main(void)
{
    int n,k,i,j,l;
    while(scanf("%d%d",&n,&k)==2)
    {
        if(n == 0 && k == 0)
            break;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        memset(ac,0,sizeof(ac));
        for(i=0;i<n;i++)
            for(j=0;j<k;j++)
                scanf("%d",&a[i][j]);
        for(i=0;i<k;i++)
            for(j=0;j<n;j++)
                scanf("%d",&b[i][j]);
        Matrix C(k);
        for(i=0;i<k;i++)
        {
            for(j=0;j<k;j++)
            {
                for(l=0;l<n;l++)
                {
                    C.m[i][j] += b[i][l]*a[l][j];  //b*a
                    C.m[i][j] %= mod;
                }
            }
        }
        C = C^(n*n-1); // b*a的n*n-1次方

        for(i=0;i<n;i++)
        {
            for(j=0;j<k;j++)
            {
                for(l=0;l<k;l++)
                {
                    ac[i][j] += a[i][l]*C.m[l][j]; // a*c
                    ac[i][j] %= mod;
                }

            }
        }
        int sum = 0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                int t = 0;
                for(l=0;l<k;l++)
                {
                    t += ac[i][l]*b[l][j]; //a*c*b
                }
                sum += t%mod;
            }
        }

        printf("%d\n",sum);
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值