BestCoder Round #73 (div.2) Rikka with Chess 1001

Rikka with Chess

 
 Accepts: 393
 
 Submissions: 548
 Time Limit: 2000/1000 MS (Java/Others)
 
 Memory Limit: 65536/65536 K (Java/Others)
Problem Description

Yuta gives Rikka a chess board of size n \times mn×m.

As we all know, on a chess board, every cell is either black or white and every two cells that share a side have different colors.

Rikka can choose any rectangle formed by board squares and perform an inversion, every white cell becomes black, and vice versa.

Rikka wants to turn all cells into the same color, please tell Rikka the minimal number of inversions she need to achieve her goal.

Input

The first line contains a number T(T \leq 10)T(T10) ——The number of the testcases.

Each testcase contains two numbers n,m(n \leq 10^9, m \leq 10^9)n,m(n109,m109).

Output

For each testcase, print a single number which represents the answer.

Sample Input
3
1 2
2 2
3 3
Sample Output
1
2
2


把偶数行翻转,把偶数列翻转,即可全部颜色相同。


#include<iostream>
#include<math.h>
using namespace std;

int main()
{
	int T;
	int n,m;
	int num;
	cin>>T;
	while(T--)
	{
		cin>>n>>m;
		num=n/2+m/2;
		cout<<num<<endl;
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值