问题 E: Double Password

题目描述

A computer at ICPC headquarters is protected by a four-digit password—in order to log in, you normally need to guess the four digits exactly. However, the programmer who implemented the password check left a backdoor in the computer—there is a second four-digit password. If the programmer enters a four-digit sequence, and for each digit position the digit entered matches at least one of the two passwords in that same position, then that four-digit sequence will log the programmer into the computer. Given the two passwords, count the number of distinct four-digit sequences that can be entered to log into the computer.

翻译

ICPC总部的一台电脑有一个四位数字的密码保护——为了登录,你通常需要准确地猜出这四位数字。然而,实现密码检查的程序员在计算机上留下了一个后门——有第二个四位数字的密码。如果程序员输入一个四位数的密码序列,并且输入的每一个数字的位置至少与两个相同位置的密码中的一个匹配,那么这个四位数的密码序列将使程序员登录计算机。给定这两个密码,计算可以输入登录计算机的不同四位数字序列的数量。

输入

The input consists of exactly two lines. Each of the two lines contains a string s (|s| = 4, s ∈ {0-9} ∗ ). These are the two passwords. 

翻译

输入正好由两行组成。两行中的每一行都包含一个字符串s (|s| = 4, s∈{0-9}∗)。这是两个密码。

输出

Output a single integer, which is the number of distinct four-digit sequences that will log the programmer into the system. 

翻译

输出一个整数,它是将程序员记录到系统中的不同的四位数序列的数量。

样例输入

【样例输入1】
1111
1234
【样例输入2】
2718
2718

样例输出

【样例输出1】
8
【样例输出2】
1

PS:关键点,排列组合

#include<iostream>
using namespace std;
int main()
{
	string a, b;
	cin >> a >> b;
	int n = 1;
	for (int i = 0; i < 4; i++) {
		if (a[i] == b[i]) {
			n *= 1;
		}
		else {
			n *= 2;
		}
	}
	cout << n;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

白凤倚剑归

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值