数据结构实验之链表四:有序链表的归并

23 篇文章 0 订阅
13 篇文章 0 订阅

数据结构实验之链表四:有序链表的归并

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
Input
第一行输入M与N的值; 
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
Output
输出合并后的单链表所包含的M+N个有序的整数。
Example Input
6 5
1 23 26 45 66 99
14 21 28 50 100
Example Output
1 14 21 23 26 28 45 50 66 99 100
Code realization
(方法一:创建新的链表归并)
#include <stdio.h>
#include <stdlib.h>
typedef struct LNode
{
	int data;
	struct LNode *next;
}LNode;

LNode *input(int n)
{
    LNode *head, *tail, *p;
    head = (LNode*)malloc(sizeof(LNode));
    tail = head;
    for(int i=0;i<n;i++)
    {
        p = (LNode*)malloc(sizeof(LNode));
        scanf("%d",&p->data);
        tail->next = p;
        tail = p;
        tail->next = NULL;
    }
    return head;
}
LNode *combine(LNode *head1,LNode *head2)
{
    LNode *p1, *p2, *p, *head, *tail;
    p1 = head1->next;
    p2 = head2->next;
    head = (LNode*)malloc(sizeof(LNode));
    tail = head;
    while(p1&&p2)
    {
        p = (LNode*)malloc(sizeof(LNode));
        if(p1->data < p2->data)
        {
            p->data = p1->data;
            p1 = p1->next;
            tail->next = p;
            tail = p;
            tail->next = NULL;
        }
        else
        {
            p->data = p2->data;
            p2 = p2->next;
            tail->next = p;
            tail = p;
            tail->next = NULL;
        }
    }
    while(p1)
    {
        p = (LNode*)malloc(sizeof(LNode));
        p->data = p1->data;
        p1 = p1->next;
        tail->next = p;
        tail = p;
        tail->next = NULL;
    }
    while(p2)
    {
        p = (LNode*)malloc(sizeof(LNode));
        p->data = p2->data;
        p2 = p2->next;
        tail->next = p;
        tail = p;
        tail->next = NULL;
    }
    return head;
}
void output(LNode *head)
{
    LNode *p;
    p = head->next;
    while(p)
    {
        printf("%d",p->data);
        p = p->next;
        if(p)
            printf(" ");
        else
            printf("\n");
    }
}

int main()
{
    LNode *head1, *head2, *head;
    int m,n;
    scanf("%d %d",&m,&n);
    head1 = input(m);
    head2 = input(n);
    head = combine(head1,head2);
    output(head);
    return 0;
}

(方法二:改变指针指向,插入归并)

#include <stdio.h>
#include <stdlib.h>
typedef struct LNode
{
	int data;
	struct LNode *next;
}LNode;

LNode *input(int n)
{
    LNode *head, *tail, *p;
    head = (LNode*)malloc(sizeof(LNode));
    tail = head;
    for(int i=0;i<n;i++)
    {
        p = (LNode*)malloc(sizeof(LNode));
        scanf("%d",&p->data);
        tail->next = p;
        tail = p;
        tail->next = NULL;
    }
    return head;
}
void combine(LNode *head1,LNode *head2)
{
    LNode *p1, *p2, *tail;
    tail = head1;
    p1 = head1->next;
    p2 = head2->next;
    while(p1&&p2)
    {
        if(p1->data < p2->data)
        {
            tail->next = p1;
            tail = p1;
            p1 = p1->next;
        }
        else
        {
            tail->next = p2;
            tail = p2;
            p2 = p2->next;
        }
    }
    if(p1)
        tail->next = p1;
    if(p2)
        tail->next = p2;
}
void output(LNode *head)
{
    LNode *p;
    p = head->next;
    while(p)
    {
        printf("%d",p->data);
        p = p->next;
        if(p)
            printf(" ");
        else
            printf("\n");
    }
}

int main()
{
    LNode *head1, *head2;
    int m,n;
    scanf("%d %d",&m,&n);
    head1 = input(m);
    head2 = input(n);
    combine(head1,head2);
    output(head1);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值