数据结构实验之链表五:单链表的拆分

13 篇文章 0 订阅
10 篇文章 0 订阅

数据结构实验之链表五:单链表的拆分

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。
Input
第一行输入整数N;;
第二行依次输入N个整数。
Output
第一行分别输出偶数链表与奇数链表的元素个数; 
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。
Example Input
10
1 3 22 8 15 999 9 44 6 1001
Example Output
4 6
22 8 44 6 
1 3 15 999 9 1001
Code realization
#include <stdio.h>
#include <stdlib.h>
typedef struct LNode
{
	int data;
	struct LNode *next;
}LNode;
int num1 = 0,num2 = 0;
LNode *input(int n)
{
    LNode *head, *tail, *p;
    head = (LNode*)malloc(sizeof(LNode));
    tail = head;
    for(int i=0;i<n;i++)
    {
        p = (LNode*)malloc(sizeof(LNode));
        scanf("%d",&p->data);
        tail->next = p;
        tail = p;
        tail->next = NULL;
    }
    return head;
}
void split(LNode *head,LNode *head1,LNode *head2)
{
    LNode *p, *tail1, *tail2;
    p = head->next;
    tail1 = head1;
    tail2 = head2;
    while(p)
    {
        if(p->data%2==0)
        {
            tail1->next = p;
            tail1 = p;
            num1++;
        }
        else
        {
            tail2->next = p;
            tail2 = p;
            num2++;
        }
        p = p->next;
    }
    tail1->next = NULL;
    tail2->next = NULL;
}
void output(LNode *head)
{
    LNode *p;
    p = head->next;
    while(p)
    {
        printf("%d",p->data);
        p = p->next;
        if(p)
            printf(" ");
        else
            printf("\n");
    }
}

int main()
{
    LNode *head, *head1, *head2;
    int n;
    scanf("%d",&n);
    head = input(n);
    head1 = (LNode*)malloc(sizeof(LNode));
    head2 = (LNode*)malloc(sizeof(LNode));
    split(head,head1,head2);
    printf("%d %d\n",num1,num2);
    output(head1);
    output(head2);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值