数据结构实验之链表七:单链表中重复元素的删除

13 篇文章 0 订阅
10 篇文章 0 订阅

数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。
Input
第一行输入元素个数n; 
第二行输入n个整数。
Output
第一行输出初始链表元素个数; 
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。
Example Input
10
21 30 14 55 32 63 11 30 55 30
Example Output
10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21
Code realization
#include <stdio.h>
#include <stdlib.h>
typedef struct LNode
{
	int data;
	struct LNode *next;
}LNode;
int n;
LNode *input(int n)
{
    LNode *head, *p;
    head = (LNode*)malloc(sizeof(LNode));
    head=NULL;
    for(int i=0;i<n;i++)
    {
        p = (LNode*)malloc(sizeof(LNode));
        scanf("%d",&p->data);
        p->next = head;
        head = p;
    }
    p = (LNode*)malloc(sizeof(LNode));
    p->next = head;
    head = p;
    return head;
}
void del(LNode *head)
{
    LNode *p, *q, *s;
    p = head;
    while(p)
    {
        q = p->next;
        s = p;
        while(q)
        {
            if(q->data == p->data)
            {
                s->next = s->next->next;
                n--;
            }
            else
                s = q;
            q = s->next;
        }
        p = p->next;
    }
}
void output(LNode *head)
{
    LNode *p;
    p = head->next;
    while(p)
    {
        printf("%d",p->data);
        p = p->next;
        if(p)
            printf(" ");
        else
            printf("\n");
    }
}
int main()
{
    LNode *head;
    scanf("%d",&n);
    head = input(n);
    printf("%d\n",n);
    output(head);
    del(head);
    printf("%d\n",n);
    output(head);
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值