HDU6300------多校2018-1C

 

Triangle Partition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 1686    Accepted Submission(s): 848
Special Judge

 

Problem Description

Chiaki has 3n points p1,p2,…,p3n . It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

 

 

Input

There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000 ) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109 ).
It is guaranteed that the sum of all n does not exceed 10000 .

 

 

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n ) each denoting the indices of points the i -th triangle use. If there are multiple solutions, you can output any of them.

 

 

Sample Input

 

1 1 1 2 2 3 3 5

 

 

Sample Output

 

1 2 3

 

题意:给你数量为3N的点(没有三点共线),将点分成N部分,构成N个三角形,且任意两个三角形都不相交。

思路:在纸上随意画点,容易发现,只要从左到右顺序取点,就能解决。

ADD:我AC时没注意到三点共线的条件,故写的比较复杂。

#include<iostream>
#include<algorithm>
#include<vector>
#include<list>
#include<queue>
#include<set>
#include<cmath>
#include<iomanip>
#include<stack>
#include<map>
#include<cstring>
#define N 300011
#define LL long long int
using namespace std;
struct node{
    int x,y;
    int item;
};
node T[N];
bool tag[N];
bool operator <(node a,node b){
    if(a.x!=b.x)
        return a.x<b.x;
    else return a.y<b.y;
}
int main(){
    ios_base::sync_with_stdio(false);
    int C;
    cin>>C;
    while(C--){
        memset(tag,0,sizeof(tag));
        int n;
        cin>>n;
        for(int i=0;i<n*3;i++){
            cin>>T[i].x>>T[i].y;
            T[i].item=i+1;
        }
        sort(T,T+n*3);
        int now=0;
        for(int i=0;i<n;i++){
            node a,b,c;
            while(tag[now]==true)
                now++;
            a=T[now];
            tag[now]=true;
            while(tag[now]==true)
                now++;
            b=T[now];
            tag[now]=true;
            if(a.x==b.x){
                int j=now+1;
                while(tag[j]==true||T[j].x==a.x)
                    j++;
                tag[j]=true;
                c=T[j];
            }
            else if(a.y==b.y){
                int j=now+1;
                while(tag[j]==true||T[j].y==a.y)
                    j++;
                tag[j]=true;
                c=T[j];
            }
            else {
                while(tag[now]==true)
                    now++;
                c=T[now];
                tag[now]=true;
            }
            cout<<a.item<<' '<<b.item<<' '<<c.item<<endl;
        }
    }
}
/*
1
2
0 0
0 1
1 2
1 1
2 0
2 1
*/

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值