HDU1011

Problem Description

You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

 

 

Input

The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.

 

 

Output

For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.

 

 

Sample Input

 

5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1

 

 

Sample Output

 

50 7

 

开始看了半天都没看懂题意,为自己的英语感到绝望。

题意:在n个洞中(树结构),每个洞有a个"bugs"和b的价值。你有m个士兵,从1号房间开始攻打,一个士兵可以打最多20个"bugs",如果要拿到某个洞的价值,需留下k个士兵消灭这个洞的所有"bugs",问你花费这m个士兵可以得到的最大价值是多少?

注意的是:必须攻打了前面的洞才能接着打后面的洞。

思路:不难想象这是背包问题,其次是在树形结构上,所以是道正正经经的树形DP问题。

转移方程:dp[p][j]=max(dp[p][j],dp[p][j-k]+dp[ son[p] ][ k ]);

具体实现参考代码备注。

#include<iostream>
#include<algorithm>
#include<vector>
#include<list>
#include<queue>
#include<set>
#include<cmath>
#include<cstring>
#include<iomanip>
#include<stack>
#include<map>
#define N 110
#define LL long long int
using namespace std;
const LL MOD=1e19;
int w[N],c[N];
vector<int> ed[N];
bool vis[N];
int dp[N][N];//dp[i][j]表示第i个洞消耗j个士兵的获得值 
int n,m;
void dfs(int x){
	vis[x]=true;
	int temp=(c[x]+19)/20;//第x个洞要消耗的士兵数量 
	for(int i=temp;i<=m;i++)
		dp[x][i]=w[x];
	for(int i=0;i<ed[x].size();i++){
		int to=ed[x][i];
		if(vis[to]==true)
			continue;
		dfs(to);
		//从叶子节点开始进行dp 
		for(int j=m;j>=temp;j--){ 
			for(int k=1;k<=j-temp;k++)//当前洞是否派出temp个士兵 
				dp[x][j]=max(dp[x][j],dp[x][j-k]+dp[to][k]);
		}
	}
	
}
int main(){
	ios_base::sync_with_stdio(false);
	int a,b;
	while(cin>>n>>m){
		if(n==-1||m==-1)
			break;
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++){
			cin>>a>>b;
			w[i]=b;
			c[i]=a;
			ed[i].clear();
			vis[i]=false;
		}
		for(int i=0;i<n-1;i++){
			cin>>a>>b;
			ed[a].push_back(b);
			ed[b].push_back(a);
		}
		if(m==0){
			cout<<"0"<<endl;
			continue;
		}
		dfs(1);
		cout<<dp[1][m]<<endl;
	}
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值