UVA oj 10071 Back to High School Physics(简单数学)

A particle has initial velocity and acceleration. If its velocity after certain time is v then what will its
displacement be in twice of that time?
Input
The input will contain two integers in each line. Each line makes one set of input. These two integers
denote the value of v (−100 ≤ v ≤ 100) and t (0 ≤ t ≤ 200) (t means at the time the particle gains
that velocity)
Output
For each line of input print a single integer in one line denoting the displacement in double of that time.
Sample Input
0 0
5 12
Sample Output
0

120

题意就是输入一个v,一个t,表示在t时间时质点的速度,问2t时间时,质点为位移。就是高中的知识,V=V0+at,x=2t * V0 + 1/2 * a * (2t)^2.整理一下就可以得到x = 2vt;

#include<cstdio>
using namespace std;

int main()
{
    int v,t;
    while(~scanf("%d%d",&v,&t))
    {
        printf("%d\n",2*v*t);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值