Hust oj 1071 Jumping Jack(贪心)

Jumping Jack
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 195(55 users)Total Accepted: 65(42 users)Rating: Special Judge: No
Description

Jack is working on his jumping skills recently. Currently he's located at point zero of the number line. He would like to get to the point x. In order to train, he has decided that he'll first jump by only one unit, and each subsequent jump will be exactly one longer than the previous one. He can go either left or right with each jump. He wonders how many jumps he needs to reach x.

Input

For each test case:
The input data consists of only one integer x ( - 10^9 <= x <= 10^9).
Process to the end of file.

Output

For each test case:
Output the minimal number of jumps that Jack requires to reach x.

Sample Input

2
6
0

Sample Output

3
3
0

想要用的步数最少,肯定就是往一个方向走到头,然后画图发现从(end - start) % 2 = 0处便可以往回走

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;

int x;

int main()
{
    while(~scanf("%d",&x))
    {
        int sum = 0;
        int re = fabs(x);
        int ans = 0;
        if(x == 0)
        {
            cout<<0<<endl;
            continue;
        }
        for(int i=1;i<=1e9;i++)
        {
            sum += i;
            int y = fabs(sum - re);
            if(y % 2 == 0 && sum >= re)
            {
                ans = i;
                break;
            }
        }
        printf("%d\n",ans);

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
hustoj.iso 是一个软件系统镜像文件。Hustoj是一个开源的在线评测系统,它被广泛应用于大学和高中的程序设计教学中。该系统的目标是提供一个方便使用的在线评测和训练环境,使学生能够提交他们的程序代码,并获得即时的评测结果。 hustoj.iso 是Hustoj的系统镜像文件,可以用来部署Hustoj系统。通过将hustoj.iso 文件安装到服务器上,就可以建立一个运行Hustoj系统的评测服务器。用户可以通过web界面访问该服务器,并提交自己的程序代码进行评测。 hustoj.iso 是一个基于Ubuntu操作系统的镜像文件。它集成了所有Hustoj系统所需要的软件和依赖项,并进行了预配置,使得安装和部署变得更加简单。用户只需要将hustoj.iso文件写入到U盘或光盘中,然后引导服务器从U盘或光盘启动,就可以开始安装Hustoj系统了。 使用hustoj.iso 部署Hustoj系统,可以为学生提供一个良好的在线评测环境,帮助他们进行程序设计的学习和训练。学生可以在该系统中提交自己的程序代码,并获得详尽的评测结果,包括运行时间、内存消耗、错误信息等等。同时,Hustoj还具有包括代码分享、竞赛组织等其他功能,能够满足不同需求的学生。 总之,hustoj.iso 是一个用于部署Hustoj系统的镜像文件,通过安装hustoj.iso,可以搭建一个功能完善、易用的在线评测环境,为程序设计学习提供有力的支持。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值