H: 奇数个的那个数

H: 奇数个的那个数
Submit Page Time Limit: 2 Sec Memory Limit: 128 Mb Submitted: 122 Solved: 46

Description
给定些数字,这些数中只有一个数出现了奇数次,找出这个数。

Input
每组数据第一行n表示数字个数,1 <= n <= 2 ^ 18 且 n % 2 == 1。
接下来n行每行一个32位有符号整数。

Output
出现奇数次那个数,每组数据对应一行。

Sample Input
5
1
1
2
2
3

7
1
2
1
2
2
3
3
Sample Output
3
2


map的使用,没有尝试迭代器。
map.find 返回迭代器,-> ,
没查到是end()
用for(x:map)然后 x.first
insert(make_pair());

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <cmath>
#include <algorithm>
#include <string>
#include <set>
#include <map>
using namespace std;

char s[10], c[10];
int A[1000000];
int main()
{
    int T;
    while (scanf_s("%d", &T) != EOF) {

        map<int,int> ss;
        for(int i=0;i<T;i++) {
            cin >> A[i];
            if (ss.find(A[i])!=ss.end()) {
                ss.find(A[i])->second++;
            }
            else ss.insert(make_pair(A[i], 1));
        }
        for (auto i : ss) {
            if (i.second %2== 1) {
                cout << i.first << endl;
                break;
            }
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值