POJ-2386___水洼 —— 解题报告 DFS

原题链接:http://poj.org/problem?id=2386

 

Lake Counting

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40211 Accepted: 19937

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

 

 

题目大意:

给出一张图,‘w’为水,以w为中心的九宫格内的w相连形成水洼,水洼与水洼之间被‘.’相隔。

问一共有几个水洼。

 

解题思路:

DFS即可

 

代码思路:

1、用二维数组存储地图

2、每次访问到的‘w’点都更改为‘.’

3、访问到的‘w’以九宫格范围dfs

4、dfs次数即为水洼个数

 

 

核心:本题关键在于访问到的点用取消标记!

代码:

 

#include <iostream>
#include<cstdio>
using namespace std;
#define maxn 105
char field[maxn][maxn];
int n,m;
void dfs(int x,int y) {
	field[x][y]='.';
	for(int dx=-1; dx<=1; dx++)
		for(int dy=-1; dy<=1; dy++) {
			int xx=x+dx,yy=y+dy;
			if(xx>=0&&xx<n&&yy<m&&yy>=0&&field[xx][yy]=='W') dfs(xx,yy);
		}
}
void solve() {
	int ans=0;
	for(int i=0; i<n; i++)
		for(int j=0; j<m; j++)
			if(field[i][j]=='W') {
				dfs(i,j);
				ans++;
			}

	cout<<ans;
}
int main() {
	std::ios::sync_with_stdio(false);
	cin>>n>>m;
	for(int i=0; i<n; i++)
		for(int j=0; j<m; j++)
			cin>>field[i][j];
	solve();
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值