HDU 4864 Task(贪心)

Task(贪心)

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K

(Java/Others)Total Submission(s): 12763 Accepted Submission(s): 3136

http://acm.hdu.edu.cn/showproblem.php?pid=4864

Problem Description

Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500xi+2yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.

Input

The input contains several test cases.
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.

Output

For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.

Sample Input
1 2
100 3
100 2
100 1
Sample Output
1 50004

Source

2014 Multi-University Training Contest 1

题意:

有n个机器,m个任务。每个机器至多能完成一个任务。对于每个机器,有一个最大运行时间xi和等级yi。对于每个任务,也有一个运行时间xj和等级yj。只有当xi>=xj且yi>=yj的时候,机器i才可以完成任务j,并获得500xj+2yj的钱。问最多完成几个任务,当出现多种情况时,输出获得金钱最多的情况。

思路:

注意看范围 xi(0<xi<1440),yi(0=<yi<=100).通过这个范围可知,时间才是最关键的因素,所以按照时间从大到小排序,如果时间相同,这时按照等级从大到小排序。使用这个排序规则来排序机器和任务。

这时可以通过遍历一遍任务,找出所有xi,使(xi >= xj)。然后再从找出的xi中找到yi最小的一个作为完成这个任务的机器。因为后面的时间肯定满足,但是等级可能不满足,所以你要从中选择等级最小的作为本次的机器。

代码:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5+5;
struct node{
    int x;
    int y;
}a[maxn],b[maxn];
bool cmp(node q1, node q2)
{
    if(q1.x == q2.x) {
        return q1.y > q2.y;
    } else
    return q1.x > q2.x;
}
int main()
{
    int n, m;
    while(~scanf("%d%d", &n, &m)) {
        for(int i = 0; i < n; i++)
            scanf("%d%d", &a[i].x, &a[i].y);
        for(int i = 0; i < m; i++)
            scanf("%d%d", &b[i].x, &b[i].y);
        sort(b, b+m, cmp);
        sort(a, a+n, cmp);
        int i = 0;

        int ans[maxn];
        memset(ans, 0, sizeof(ans));
        int count = 0;
        long long sum = 0;
        for(int j = 0; j < m; j++) {
            while(a[i].x >= b[j].x && i < n) {
                ans[a[i].y]++;
                i++;
            }
            for(int k = b[j].y ; k <= 100 ;k++) {
                if(ans[k]) {
                    ans[k]--;
                    count++;
                    sum += (long long)(500*b[j].x + 2 * b[j].y);
                    break;
                }
            }

        }


        printf("%d %lld\n",count,sum);
    }


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值