PTA|How Long Does It Take

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N−1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i], E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output “Impossible”.

Sample Input 1:

9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4

Sample Output 1:

18

Sample Input 2:

4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5

Sample Output 2:

Impossible

代码:

#include<stdio.h>
#include<stdlib.h>

#define MaxVertexNum 102
typedef int EdgeType;
typedef int VertexType;
typedef int WeightType;

//有向边<v1,v2>
struct ENode {
	EdgeType v1, v2;
	WeightType wt;
};
typedef struct ENode* PtrToENode;

//顶点
struct VNode {
	VertexType adjv;
	WeightType wt;
	struct VNode* Next;
};
typedef struct VNode* PtrToVNode;


//顶点表头
typedef struct VHead {
	PtrToVNode firstVertex;
	int EarlistTime;
}AdjList[MaxVertexNum];

//图结点
struct GNode {
	int Vnum, Enum;
	AdjList vertice;
};
typedef struct GNode* PtrToGNode;
typedef PtrToGNode Graph;

//过程:排序
void InsertEdge(Graph G, PtrToENode Edge){
	PtrToVNode V = (PtrToVNode)malloc(sizeof(struct VNode));
	V->adjv = Edge->v2;
	V->wt = Edge->wt;
	V->Next = G->vertice[Edge->v1].firstVertex;
	G->vertice[Edge->v1].firstVertex= V;
}

Graph BuildGraph() {
	Graph G = (Graph)malloc(sizeof(struct GNode));
	PtrToENode Edge = (PtrToENode)malloc(sizeof(struct ENode));
	scanf("%d %d", &(G->Vnum), &(G->Enum));
	for (int i = 0; i < G->Vnum; i++) {//初始化,避免野指针
		G->vertice[i].firstVertex = NULL;
		G->vertice[i].EarlistTime = 0;
	}
	for (int i = 0; i < G->Enum; i++) {
		scanf("%d %d %d", &(Edge->v1), &(Edge->v2), &(Edge->wt));
		InsertEdge(G, Edge);
	}
	return G;
}

int Sort(Graph G) {
	int indegree[MaxVertexNum] = { 0 };
	int queue[MaxVertexNum + 1], front = 0, rear = 0;
	VertexType Order[MaxVertexNum]; int count = 0;
	PtrToVNode w = (PtrToVNode)malloc(sizeof(struct VNode));
	for (int i = 0; i < G->Vnum; i++) {
		for (w = G->vertice[i].firstVertex; w; w = w->Next) {
			indegree[w->adjv]++;
		}
	}

	for (int i = 0; i < G->Vnum; i++) {
		if (indegree[i] == 0) {
			queue[rear++] = i;//入队
		}
	}
	while (front != rear) {//队不为空
		int v = queue[front++];//出队
		Order[count++] = v;
			for (w = G->vertice[v].firstVertex; w; w = w->Next) {
				if (G->vertice[w->adjv].EarlistTime < G->vertice[v].EarlistTime + w->wt)
					G->vertice[w->adjv].EarlistTime = G->vertice[v].EarlistTime + w->wt;
				if (--indegree[w->adjv] == 0) {
					queue[rear++] = w->adjv;
				}
			}
	}
		if (count == G->Vnum)
			return 1;
		else
			return 0;
	}


int main() {
	int max=0;
	Graph G=BuildGraph();
	int flag=Sort(G);
	if (flag == 1) {
		for (int i = 0; i < G->Vnum; i++) {
			if (G->vertice[i].EarlistTime > max)
				max = G->vertice[i].EarlistTime;
		}
		printf("%d\n", max);
	}
	else
		printf("Impossible\n");

	return 0;
}

方法参考:https://blog.csdn.net/authur520/article/details/86593211

坑:一定要int main然后return 0 不然是“非零返回”错误。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值