学长只能帮你到这儿了00-HDU2560

Buildings

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1598    Accepted Submission(s): 1357

Problem Description

We divide the HZNUCampus into N*M grids. As you can see from the picture below, the green gridsrepresent the buidings. Given the size of the HZNU Campus, and the color ofeach grid, you should count how many green grids in the N*M grids.

 

 

Input

Standard inputwill contain multiple test cases. The first line of the input is a singleinteger T which is the number of test cases. T test cases follow.
The first line of each test case contains two integers n andm(1<=n,m<=100), the size of the campus. Then follow n lines, each linecontaining m integers. The j-th integer in the i-th line is the color of thatgrid, 0 stands for white color, while 1 stands for green.

 

 

Output

Results should be directed to standard output. For eachcase, output an integers T, the total green grids in the N*M size campus.

 

 

Sample Input

2

2 2

1 1

0 0

3 3

1 0 1

0 0 1

1 1 0

 

 

Sample Output

2

5

 

#include<stdio.h>
 
int main()
{
   int t,n,m;
   int c,cont;
   int i,j;
   scanf("%d",&t);
   while(t--)
   {
      scanf("%d%d",&n,&m);
      cont=0;
      for(i=0;i<n;i++)
        for(j=0;j<m;j++)
        {
          scanf("%d",&c);
          if(c==1)cont++;
        }
      printf("%d\n",cont);
   }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值