Buildings
Time Limit: 2000/1000 MS(Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1598 Accepted Submission(s): 1357
Problem Description
We divide the HZNUCampus into N*M grids. As you can see from the picture below, the green gridsrepresent the buidings. Given the size of the HZNU Campus, and the color ofeach grid, you should count how many green grids in the N*M grids.
Input
Standard inputwill contain multiple test cases. The first line of the input is a singleinteger T which is the number of test cases. T test cases follow.
The first line of each test case contains two integers n andm(1<=n,m<=100), the size of the campus. Then follow n lines, each linecontaining m integers. The j-th integer in the i-th line is the color of thatgrid, 0 stands for white color, while 1 stands for green.
Output
Results should be directed to standard output. For eachcase, output an integers T, the total green grids in the N*M size campus.
Sample Input
2
2 2
1 1
0 0
3 3
1 0 1
0 0 1
1 1 0
Sample Output
2
5
#include<stdio.h>
int main()
{
int t,n,m;
int c,cont;
int i,j;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
cont=0;
for(i=0;i<n;i++)
for(j=0;j<m;j++)
{
scanf("%d",&c);
if(c==1)cont++;
}
printf("%d\n",cont);
}
}