学长只能帮你到这儿了00-HDU1064

Financial Management

Time Limit: 400/200 MS(Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6490    Accepted Submission(s): 4035

Problem Description

Larry graduated this year and finally has a job. He’smaking a lot of money, but somehow never seems to have enough. Larry hasdecided that he needs to grab hold of his financial portfolio and solve hisfinancing problems. The first step is to figure out what’s been going on withhis money. Larry has his bank account statements and wants to see how muchmoney he has. Help Larry by writing a program to take his closing balance fromeach of the past twelve months and calculate his average account balance.

 

 

Input

The input will be twelve lines. Each line will containthe closing balance of his bank account for a particular month. Each numberwill be positive and displayed to the penny. No dollar sign will be included.

 

 

Output

The output will be a single number, the average (mean) ofthe closing balances for the twelve months. It will be rounded to the nearestpenny, preceded immediately by a dollar sign, and followed by the end-of-line.There will be no other spaces or characters in the output.

 

 

Sample Input

100.00

489.12

12454.12

1234.10

823.05

109.20

5.27

1542.25

839.18

83.99

1295.01

1.75

 

 

Sample Output

$1581.42

 

#include <stdio.h>
#include <stdlib.h>
 
int main()
{
    float a,s=0;
    int i;
    for(i=0;i<12;i++){
        scanf("%f",&a);
        s+=a;
    }
    s/=12;
    printf("$%.2f\n",s);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值