UVA - 11991 Easy Problem from Rujia Liu?

Though Rujia Liu usually sets hard problems for contests (for example, regional contests like Xi’an 2006, Beijing 2007 and Wuhan 2009, or UVa OJ contests like Rujia Liu’s Presents 1 and 2), he occasionally sets easy problem (for example, ‘the Coco-Cola Store’ in UVa OJ), to encourage more people to solve his problems :D

Given an array, your task is to find the k-th occurrence (from left to right) of an integer v. To make the problem more difficult (and interesting!), you’ll have to answer m such queries.
Input
There are several test cases. The first line of each test case contains two integers n, m (1 ≤ n, m ≤ 100,000), the number of elements in the array, and the number of queries. The next line contains n positive integers not larger than 1,000,000. Each of the following m lines contains two integer k and v (1 ≤ k ≤ n, 1 ≤ v ≤ 1, 000, 000). The input is terminated by end-of-file (EOF).
Output
For each query, print the 1-based location of the occurrence. If there is no such element, output ‘0’ instead.
Sample Input
8 4 
1 3 2 2 4 3 2 1 
1 3
2 4
3 2
4 2
Sample Output
2 
0
7
0

给定一个数组,求出第A个B出现的位置。

STL::map

at函数的使用(C11) http://www.cplusplus.com/reference/map/map/at/

#include <iostream>
#include <stack>
#include <queue>
#include <vector>
#include <cstdio>
#include <map>
using namespace std;
int n,m;
const int maxn = 1e5 + 5;
int num;
int a, b;
int main() {
    while(cin >> n >> m) {
        map<int, vector<int> > m1;
        for(int i = 1;i <= n;i++){
            cin >> num;
            m1[num].push_back(i);
        }
        while(m--) {
            cin >> a >> b;
            if(!m1.count(b) || m1[b].size() < a)
                cout << 0 << endl;
            else
                cout << m1[b].at(a - 1) << endl; //vector begin at 0
        }
    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值