POJ 1990 MooFest

105 篇文章 0 订阅
28 篇文章 0 订阅

Description

Every year, Farmer John's N (1 <= N <= 20,000) cows attend "MooFest",a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing. 

Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)). 

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume. 

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location. 

Output

* Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows. 

Sample Input

4
3 1
2 5
2 6
4 3

Sample Output

57

Source

USACO 2004 U S Open

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

树状数组+很神奇的思路~

把牛排序,然后建两个树状数组,分别存左面的牛和右面的牛,每次分别计算和即可。

但是我又出现了新错!求和循环的时候加的是j不是u!检查了2小时+……


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define ll long long

int n,le[20005],ri[20005],k1,k2,k3;
ll sum,tot;

struct node{
	int num,val;
}a[20005];

bool cmp(node u,node v)
{
	return u.val<v.val;
}

int lowbit(int u)
{
	return u&(-u);
}

void leadd(int u,int v)
{
	for(int j=u;j<=20050;j+=lowbit(j)) le[j]+=v;
}

ll legetnum(int u)
{
	ll ans=0;
	for(int j=u;j;j-=lowbit(j)) ans+=le[j];  //是j不是u啊啊啊啊 
	return ans;
} 

void riadd(int u,int v)
{
	for(int j=u;j<=20050;j+=lowbit(j)) ri[j]+=v;
}

int rigetnum(int u)
{
	int ans=0;
	for(ll j=u;j;j-=lowbit(j)) ans+=ri[j];
	return ans;
}

int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		memset(le,0,sizeof(le));
		memset(ri,0,sizeof(ri));
		for(int i=1;i<=n;i++) scanf("%d%d",&a[i].val,&a[i].num);
		sort(a+1,a+n+1,cmp);tot=0;
		for(int i=1;i<=n;i++)
		{
			leadd(a[i].num,a[i].num);
			riadd(a[i].num,1);
			if(i==1)
			{
				sum=a[i].num;continue;
			}
			k1=rigetnum(a[i].num);
			k2=i-k1-1;
			k3=legetnum(a[i].num);
			tot+=a[i].val*(a[i].num*(k1-k2)+sum-2*k3);
			sum+=a[i].num;
		}
		printf("%lld\n",tot);
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值