poj 1990 MooFest (树状数组)

MooFest

Time Limit: 1000MS Memory Limit: 30000K

Description

Every year, Farmer John’s N (1 <= N <= 20,000) cows attend “MooFest”,a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing.

Each cow i has an associated “hearing” threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)).

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume.

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows.

Input

  • Line 1: A single integer, N

  • Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location.

Output

  • Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows.

Sample Input

4
3 1
2 5
2 6
4 3

Sample Output

57


嗯……题目先贴出来,改天再写思路……
代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <cmath>
#include <string>
#include <queue>
#include <stack>
#define INF 0x3f3f3f3f
#define mem(x,val) memset(x,val,sizeof(x))
#define SI(x) scanf("%d",&x)
#define MAX 20000+10

using namespace std;
typedef long long ll;

struct cow{
    int v,x;
}c[MAX];

int t1[MAX],t2[MAX],s[MAX];
int lowbit(int x)
{
    return x&(-x);
}

void update(int pos,int v,int t[],int n)
{
    while(pos<=n)
    {
        t[pos]+=v;
        pos+=lowbit(pos);
    }
}

int sum(int pos,int t[])
{
    int ans=0;
    while(pos>0)
    {
        ans+=t[pos];
        pos-=lowbit(pos);
    }
    return ans;
}

bool cmp(cow x,cow y)
{
    return x.v<y.v;
}
int main()
{
    int n,i;
    while(SI(n)!=EOF)
    {
        ll msum=0;
        ll lessx,morex,lessnum,morenum;
        int max_x=0;
        for(i=1;i<=n;i++)
            scanf("%d%d",&c[i].v,&c[i].x);
        sort(c+1,c+n+1,cmp);
        mem(t1,0);
        mem(t2,0);
        mem(s,0);
        for(i=1;i<=n;i++)
        {
            s[i]=s[i-1]+c[i].x;
            max_x=max(c[i].x,max_x);
        }
        for(i=1;i<=n;i++)
        {
            update(c[i].x,c[i].x,t1,max_x);
            update(c[i].x,1,t2,max_x);
            lessnum=sum(c[i].x-1,t2);
            lessx=sum(c[i].x-1,t1);
            morenum=i-1-lessnum;
            morex=s[i-1]-lessx;
            msum+=(c[i].x*lessnum-lessx+morex-c[i].x*morenum)*c[i].v;
        }
        printf("%lld\n",msum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值