HDU 2824 The Euler function

38 篇文章 0 订阅
11 篇文章 0 订阅

Problem Description
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
 

Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
 

Output
Output the result of (a)+ (a+1)+....+ (b)
 

Sample Input
  
  
3 100
 

Sample Output
  
  
3042
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2818  2825  2817  2822  2821 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

线性筛求欧拉函数~


用到的性质是:

(1)当p是质数时,φ(p)=p-1;

(2)如果i%p==0,那么φ(i*p)=p*φ(i).


然后,输入是多组数据……


#include<cstdio>

int x,y,a[3000001],phi[3000001];
long long tot;
bool b[3000001];

void findd(int u)
{
	phi[1]=1;
	for(int i=2;i<=u;i++)
	{
		if(!b[i])
		{
			a[++a[0]]=i;phi[i]=i-1;
		}
		for(int j=1;j<=a[0];j++)
		{
			if(a[j]*i>u) break;
			b[a[j]*i]=1;
			if(i%a[j]==0)
			{
				phi[a[j]*i]=phi[i]*a[j];break;
			}
			phi[a[j]*i]=phi[i]*(a[j]-1);
		}
	}
}

int main()
{
	findd(3000000);
	while(scanf("%d%d",&x,&y)==2)
	{
		tot=0;
		for(int i=x;i<=y;i++) tot+=(long long)phi[i];
		printf("%lld\n",tot);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值