UVa 12034 Race

42 篇文章 0 订阅

Disky and Sooma, two of the biggest mega minds of Bangladesh went to a far country. They ate, coded and wandered around, even in their holidays. They passed several months in this way. But everything has an end. A holy person, Munsiji came into their life. Munsiji took them to derby (horse racing). Munsiji enjoyed the race, but as usual Disky and Sooma did their as usual task instead of passing some romantic moments. They were thinking- in how many ways a race can finish! Who knows, maybe this is their romance!

In a race there are n horses. You have to output the number of ways the race can finish. Note that, more than one horse may get the same position. For example, 2 horses can finish in 3 ways.

  1. Both first
  2. horse1 first and horse2 second
  3. horse2 first and horse1 second

Input 

Input starts with an integer  T  ( $ \le$1000 ), denoting the number of test cases. Each case starts with a line containing an integer  n  (   1$ \le$n$ \le$1000 ).

Output 

For each case, print the case number and the number of ways the race can finish. The result can be very large, print the result modulo 10056.

Sample Input 

3
1
2
3

Sample Output 

Case 1: 1
Case 2: 3
Case 3: 13

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

组合数~

分为第一有1人,有2人,……,有n人的情况,则分别可以转化为前面求过的f值,公式为∑C(n,i)f(n-i)。


#include<cstdio>
#define modd 10056

int t,n,cnt,c[1001][1001],f[1001];

void findd()
{
	c[0][0]=1;f[0]=1;
    for(int i=1;i<=1000;i++)
    {
        c[i][0]=c[i][i]=1;f[i]=0;
        for(int j=1;j<i;j++) c[i][j]=(c[i-1][j-1]+c[i-1][j])%modd;
        for(int j=1;j<=i;j++) f[i]=(f[i]+c[i][j]*f[i-j]%modd)%modd;
	}
}

int main()
{
	findd();
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		printf("Case %d: %d\n",++cnt,f[n]);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值