POJ 3254 Corn Fields

105 篇文章 0 订阅

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Source

USACO 2006 November Gold

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

状压DP~

基础题?

用二进制数记录每一行的状态(先预处理出每行中草不相邻的状态),然后通过位运算判断是否上下相邻以及符合该行的要求,最后直接把所有状态加起来就可以了~

检查了一节课啊……在学校输出样例还是8回来就是9了……为什么啊好奇怪……


#include<cstdio>
#define modd 100000000

int n,m,x,a[13],cas[8200],f[8200][13],tot,ans;

bool che(int u)
{
	return !(u&(u<<1));
}

int main()
{
	scanf("%d%d",&n,&m);tot=(1<<m)-1;
	for(int i=1;i<=n;i++)
      for(int j=0;j<m;j++) scanf("%d",&x),a[i]+=(x^1)*(1<<j);
    for(int i=0;i<=tot;i++)
      if(che(i))
	  {
	  	cas[++cas[0]]=i;
		if(!(i&a[1])) f[cas[0]][1]=1;
	  }
	for(int i=2;i<=n;i++)
	  for(int j=1;j<=cas[0];j++)
	    if(!(cas[j]&a[i]))
	    {
	    	for(int k=1;k<=cas[0];k++)
	          if(!(cas[k]&a[i-1]) && !(cas[k]&cas[j])) f[j][i]=(f[j][i]+f[k][i-1])%modd;
		}
	for(int i=1;i<=cas[0];i++) ans=(ans+f[i][n])%modd;
	printf("%d\n",ans);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值