UVa 10154 Weights and Measures

42 篇文章 0 订阅
I know, up on top you are seeing great sights,
But down at the bottom, we, too, should have rights.
We turtles can’t stand it. Our shells will all crack!
Besides, we need food. We are starving!” groaned Mack.
Mack, in an effort to avoid being cracked, has enlisted your advice as to the order in which turtles
should be dispatched to form Yertle’s throne. Each of the five thousand, six hundred and seven turtles
ordered by Yertle has a different weight and strength. Your task is to build the largest stack of turtles
possible.
Input
Standard input consists of several lines, each containing a pair of integers separated by one or more
space characters, specifying the weight and strength of a turtle. The weight of the turtle is in grams.
The strength, also in grams, is the turtle’s overall carrying capacity, including its own weight. That is,
a turtle weighing 300g with a strength of 1000g could carry 700g of turtles on its back. There are at
most 5,607 turtles.
Output
Your output is a single integer indicating the maximum number of turtles that can be stacked without
exceeding the strength of any one.
Sample Input
300 1000
1000 1200
200 600
100 101
Sample Output

3

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

DP~

n只乌龟,每只有承受重量的上限str(包含自身)和重量wei,求最多能叠多少层。

经典DP,从背包演化而来。

先把乌龟按照承受能力从小到大排序。

然后用f[i][j]表示DP到第i只乌龟,已经有i层的最小总重量,那么f[i][j]=min(f[i-1][j],f[i-1][j-1]+wei[i]),需要判断乌龟i是否能承载所有的重量。

最后最大的使得f[n][i]不为inf的i就是答案。

(输入必须写成我那样,不能直接while……并不知道为什么……)


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

int n,f[5610][5610],inf;

struct node{
	int str,wei;
}a[5610];

bool operator < (node u,node v)
{
	return u.str==v.str ? u.wei<v.wei:u.str<v.str;
}

int main()
{
	n=1;
	while(scanf("%d%d",&a[n].wei,&a[n].str)!=EOF) n++;n--;
	sort(a+1,a+n+1);
	memset(f,127/3,sizeof(f));inf=f[0][0];
	for(int i=0;i<=n;i++) f[i][0]=0;
	for(int i=1;i<=n;i++)
	  for(int j=1;j<=i;j++)
	  {
	  	f[i][j]=f[i-1][j];
	  	if(a[i].wei+f[i-1][j-1]<=a[i].str && f[i-1][j-1]!=inf)
	  	  f[i][j]=min(f[i][j],f[i-1][j-1]+a[i].wei);
	  }
	for(int i=n;i;i--)
	  if(f[n][i]!=inf)
	  {
	  	printf("%d\n",i);return 0;
	  }
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值