PAT甲级1113 Integer Set Partition (25分)

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A​1 and A​2​​ of n​1 and n​2numbers, respectively. Let S1and S2 denote the sums of all the numbers in A​1and A​2​​ , respectively. You are supposed to make the partition so that ∣n​1 −n​2​​ ∣ is minimized first, and then ∣S​1−S2∣ is maximized.
Input Specification:
Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10​^5), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2^31
​​ .Output Specification:
For each case, print in a line two numbers: ∣n​1−n​2∣ and ∣S​1−S​2∣, separated by exactly one space.
Sample Input 1:
10
23 8 10 99 46 2333 46 1 666 555
Sample Output 1:
0 3611
Sample Input 2:
13
110 79 218 69 3721 100 29 135 2 6 13 5188 85
Sample Output 2:
1 9359
这是一道408真题,目的是把原来的数据分成两个数组这两个数组元素数最接近且和相差最大。容易想到把小的元素放在一个数组里把大的元素放在另一个数组,且存放大元素的那个数组的大小永远等于另一个数组或大一个单位;
AC代码:

#include<algorithm>
#include<iostream>
#include<cstdio>
using namespace std;
const int maxn=100001;
int main(){
int n;
int a[maxn];
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n);
int num1=0,num2=0;
for(int i=0;i<n/2;i++)
    num1+=a[i];
for(int i=n/2;i<n;i++)
    num2+=a[i];
printf("%d %d",n%2,num2-num1);
system("pause");
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值