PAT 甲级1113 Integer Set Partition

1113 Integer Set Partition

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A1 and A2 of n1 and n2 numbers, respectively. Let S1 and S2 denote the sums of all the numbers in A1 and A2, respectively. You are supposed to make the partition so that ∣n1−n2∣ is minimized first, and then ∣S1−S2∣ is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤105), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 231.

Output Specification:

For each case, print in a line two numbers: ∣n1−n2∣ and ∣S1−S2∣, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

给出的 n 个整数分成两个不相交的集合,元素个数差值最小同时元素之和差值最大。因此把元素从小到大排序,最小的 n/2 个数是第一个集合,剩下的是第二个。总元素个数为偶数时两个集合元素个数差值 0,否则是 1;注意 sum1sum2 一定要把初始值置为 0

时间复杂度 O(n),空间复杂度 O(1)

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int main() {
	int n, i, sum1 = 0, sum2 = 0;
	scanf("%d", &n);
	vector<int> v(n);
	for(i = 0; i < n; ++i) {
		scanf("%d", &v[i]);
	}	
	sort(v.begin(), v.end());
	for(i = 0; i < n/2; ++i)	sum1 += v[i];
	for(; i < n; ++i)	sum2 += v[i];
	printf("%d %d\n", n % 2, sum2 - sum1);
	return 0;
} 
测试点结果耗时内存
0答案正确3 ms256 KB
1答案正确4 ms384 KB
2答案正确30 ms768 KB
3答案正确17 ms876 KB
4答案正确5 ms384 KB

进一步的优化可以在读取所有元素时计算总和 sum,排序后计算前 n/2 的元素和 sum1 ,两个集合的差值为 sum - 2 * sum1

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int main() {
	int n, sum = 0, sum1 = 0;
	scanf("%d", &n);
	vector<int> v(n);
	for(int i = 0; i < n; ++i) {
		scanf("%d", &v[i]);
		sum += v[i];
	}	
	sort(v.begin(), v.end());
	for(int i = 0; i < n/2; ++i)	sum1 += v[i];
	printf("%d %d\n", n % 2, sum - 2 * sum1);
	return 0;
} 
测试点结果耗时内存
0答案正确3 ms424 KB
1答案正确3 ms356 KB
2答案正确31 ms740 KB
3答案正确23 ms808 KB
4答案正确3 ms224 KB
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值